0

Hello,
I'm facing this problem since a long time and unable to resolve it.When I double click on my drive volumes(C:\,E:\....) in My computer Window it doesn't open instead shows some error i.e Access is Denied but when I right click on the volume (C:\,E:\...) and select open then I'm able to open the volume. Please help me I'm totally irritated by this problem.

17
Contributors
56
Replies
57
Views
10 Years
Discussion Span
Last Post by digudc
0

You need to set permissions on those volumes. Also, you need higher level account (administrator level is the highest).

To check whether your account is administrator one, open the control panel (classic view) and open "User Accounts". In the lower left corner should be your account name and account type (should read "computer administrator")

To set permissions follow these steps:
Open control panel (classic view)/folder options. Scroll down advanced settings window and uncheck the "use simple file sharing".
Apply and rightclick on the volumes in question, select properties and click on "security" tab. There you'll see detailed sharing permissions/restrictions for all relevant accounts on that particular drive/file/folder. (Taking that you have administrative permissions) click on "Administrators ([computer name]\Administrators)" (first one from the top) and check allow on "full control" and click "apply".
If you see your account name on the list, either remove it or allow full control. If you are only user on that PC I suggest removing it from the list, for you are administrator and comply with "administrators" permissions.
After setting the permission, click on the "advanced" button. In the first tab select "Administrators ([computer name]\Administrators)" (same as before) and check the "Replace permissions entries on all child objects with entries shown here that apply to child objects" and apply.

Repeat those steps on all volumes in question.

0

I'm sorry but I'm using Windows XP home edition and I didn't find any such option like advance setting in my folder option window neither did i find any such security tab on right clicking the drive and selecting properties.Please help I'm still facing the same problem.

0

hello

plz post hijackthis log
also tell me wt all thing u get in the list when you right ckick the drives, n in bold fonts.
(eg: open, explore, search, copy,.. properties)

try this
-------
open my comp>goto tools>folder options
select "show hidden files"
uncheck "show system files"

goto each drive by rightclick>explore only. DONOT double click drives.

delete the file with the name "autorun.inf"

restart comp OR endtask n run explorer.exe thru taskmanager

this will solve the problem....


precaution
-----------
these setting are done by many viruses which spreads thru removable media.
never double click removable drives
always right click n do explore/open

0

No such autorun.inf file found and u told me to list the items shown on right clicking the drive. They all r ok as they should be but only one item i.e open option is twice,once as open(0) which on selection gives the error and other as open which gives me access to the drive.

0

No man , actually this problem started since my antivirus detected ctfmon.exe being corrupted by a virus ctfmon.vir

0

ya, this is probably ctfmon.ex e virus

check this:
C:\Documents and Settings\<username>\Start Menu\Programs\Startup
do u see ctfmon.e xe

or do a search for this file
do not delete the file in the windows folder

to see hidden file
-----------------
do u know making changes in registries to show hidden files... then do it

0

No its not there in C:\Documents and Settings\Owner\Start Menu\Programs\Startup.But ya i can find it in my system32 folder wht should i do ?

0

ok. try using dos..

run> "COMMAND"
type :

del c:\autorun.inf
del d:\autorun.inf
del e:\autorun.inf
......
tell me if u get error

if no error then restrt windows

0

try this registry:
copy the following code in notepad and save as "xyz.reg" and merge it......

REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Hidden"=dword:00000001

hope u'll b able to see the hidden files now...

0

Try this:

Click "run" on your start menu and type regedit.

In "HKEY_CLASSES_ROOT" branch (first one from the top) find "drive" sub-branch. Easiest way to find it is to expand the branch, click on the first sub-branch ant simply type in "drive".
Now expand it and click on the "shell". If there is anything in the data for the (Default) value, delete it. That data is the reference to the shell sub-branch for default action when double-clicking the drive icon. If you like, you can export the "drive" branch to a file just in case you delete something vital. (no undo function)

0

no use but ya i can se hidden files and there is no such file like autorun.inf

0

Can you not do a virus scan? Most up-to-date virus protection software such as avast should be able to detect and repair the corrupted windows program..

0

ufff....

try this,
run gpedit.msc

goto user config>admin temp>system>turn off auto play>
check enabled,
turn of autoplay on all drives...

this is the last effort from my side...
if this doesn't work, then there's some other problem, that i don't know

gud luck!!!

0

oh now i know why the delete command didn't work:
i copied the autiorun on my drive n tried to delete it simply but it didn't do coz
autorun is a system file ./....
n aslo u hav to delete is forcefully...
(u cannot see this file until u uncheck "hide system file" in the tools>options)

d:\del autorun.inf /a /f

or

d:\del autorun.inf /as /f

0

Can you not do a virus scan? Most up-to-date virus protection software such as avast should be able to detect and repair the corrupted windows program..

hey josh!
i should tell u that antiviruses can delete the firus files,...
but they don't heal everything done to your system...

here autorun.inf is an important system file (that supports autoplay of cds, etc..) that is misused by the viruses... :)

0

.. actually, if you have good virus protection software, then it can. Avast offers a backup utility than can be used to revert infected/corrupted system files.. which would have fixed you up instantly :)

0

There should NOT be autorun.inf in HD volume root. If you have one, delete it. Try typing this in "run" menu to reveal it:

attrib C:\autorun.inf -r -h -s

or

attrib D:\autorun.inf -r -h -s


that should make it visible and easy do delete. It is NOT important system file. It is only MARKED as system file.

0

OMG does none here use XP Home?

There is NO gpedit. The group policy editor does not exist in XP home. Neither does any advanced filesharing. XP home uses simple filesharing ONLY

It is likely that the virus corrupted a system file. Try going to run and tyoing sfc /scannow (you will need yoru XP cd)

0

I am using Windows XP SP2 and I have the same problem. I can not open volume drives (particularly removable drives/usb hdd) by double clicking. It always says "access denied". But if explored or opened via right click, then it can be viewed.

Though it is a small issue, it is quite irritating. But who knows if it will bring more trouble in the future. Some says that it is caused by a virus. Some adviced me to try "Karspersky anti virus" but i am having a hard time installing it since it is prompting me to uninstall my mcafee(which i wont do).

I just hope that somebody can share a step by step procedure on resolving and explaining this matter. He/she can definitely help a lot of pc users.

Thanks:'(

0

Try my advice.

You can trace the program that caused this by opening "command" sub-key of of the sub-key indicated in the "default" value. That is the actual command line that activates a program.
Also check your permissions on those drives and check for "autorun.inf".

You might want to post what is the default (bold) command when you right-click on the drive. That is set by "default" value in above mentioned "HKEY_CLASSES_ROOT\Drive\shell" registry key.

0

hey people.
i learnt a few thing abt autorun.inf
it could be used to get a new command (bold font/default) for the drives for double click., like Open(0) ,etc. (used by ctfmon.exe virus, adobeR.exe virus, autorun.exe virus..)

now this thing is used by viruses. since no one will click any unknown exe file in pen drives, etc. the virus writers use this property. once u double click the drive, the autorun.inf directs to the virus, and the virus gets activated, installed,....etc

even the normal/default Open can be directed to run any program (used by SSVICHOSST.exe virus) ... and likewise Explore and Search... etc.

hope m right....

0

Pardon my ignorance my friends. Im afraid that my literacy level about the topic may not be as you have expected.

If it's not much for you...I will really appreciate if you can give me a more detailed procedure on how i can work this out.


As what the movie says:
"Can you explain it to me like I am a 5 year old kid?"


Thanks for understanding

0

I hate to repeat my self.

Well, here's for the 5-year-olds:

- click "run" in your start menu and type in "regedit". That should start the registry editor.
- if there are expanded branches in your first run, collapse them all and expand one called "HKEY_CLASSES_ROOT". First one from the top.
- find key called "drive" on the next level. Expand it and click on the "shell" sub-key. (pic no. 1)
The picture shows what your registry should look like. Note the status bar at the bottom says "My Computer\HKEY_CLASSES_ROOT\Drive\shell" - exact location of where you should look. Also note on the right side "default REG_SZ none". You can ignore REG_SZ part. Important thing there is that default - none. That is what it should read on your PC. Let's say that in my case the default value says "ACDBrowse", then the picture No. 3 shows what exactly would be activated ("C:\Program Files\ACD Systems\ACDSee\8.0.Pro\ACDSee8Pro.exe" "%1") on the double-click. ACDSee would start. Also, on the right click, first (bold text) item would be what the picture No 2 shows "Browse with ACDSee Pro" - user-friendly name of "ACDBrowse" sub-key.


The conclusion: In the "HKEY_CLASSES_ROOT\Drive\shell" key the default value should be "none". (as text, not empty)


One more thing:

DO NOT DELETE ANY KEYS!
ONLY CHANGE THE DEFAULT VALUE OF THE ABOVE KEY!
THERE IS NO UNDO FUNCTION IN REGISTRY EDITOR!

Attachments 1.png 30.74 KB 2.png 31.39 KB 3.png 32.17 KB
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.