0

i found some topic about this issue but they can't solve my problem .

i have CSS menu with .swf file and this is code of flash

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="768" height="300; ">
                          <param name="movie" value="slideshow2.swf">
                          <param name="quality" value="high">
                          <param name=wmode value="transparent">
                           <DIV ID="flashMovie" STYLE="position: absolute; top: 10; left: 10; width: 550; height: 400; z-index: 1;">
                          <embed src="slideshow2.swf" wmode="transparent" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="768" height="300"></embed>
                         </DIV></object>
6
Contributors
8
Replies
9
Views
7 Years
Discussion Span
Last Post by kk6terry
0

The z-index determines the stack order on the page. Increase the z-index in your menu and your problem should be fixed.

For example, if your menu is in a a div called menu, add this:

#menu
{
z-index:1000;
}
0

i have add your code but still dose not work . i really confuse

0

The z-index determines the stack order on the page. Increase the z-index in your menu and your problem should be fixed.

For example, if your menu is in a a div called menu, add this:

#menu
{
z-index:1000;
}

That is CSS code, so it goes in your stylesheet.

If it does not fix it, please paste a link to your page.

of course i didn't edit style.css and just working on index file . tanx if you edit or help me
http://nooriccco.com/index2.htm
http://nooriccco.com/index2.htm/style.css

0

either edit the style, and change the z-index as noted to put the menu in front of the slideshow, or change the location of the div containing the .swf top: ; left: ; to put it below the menu in the pagenote::; those numbers should be dimensioned (as px pt em %) only zero(0) is permitted to be dimensionless
Browser quirks mode (also described as 'where did my page go?' ) does not display as intended

Edited by almostbob: n/a

0

wmode often has a bearing here. Try changing the value to opaque if the menu if getting hidden behind it.

0

And remember, if you are viewing this page on a Linux machine, the menu will always be behind the flash. On a Linux machine, no matter what you try flash will always be on top.

0

ardav is on the button. I had the same problem as you on one of my sites. Setting wmode to opaque solved the problem. Understand that you have to add it BOTH to the object AND to the embed.

In the object:

<param name="wmode" value="opaque" />

In the embed:

wmode="opaque"

Edited by kk6terry: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.