0

I had the following code in my .htaccess file to enable Gzip compression:

<ifModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>

# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

# Or, compress certain file types by extension:
<files *.html>
SetOutputFilter DEFLATE
</files>

Now if I want to remove the gzip compression, how can I do so?

I tried deleting the file (didn't work) or entering ONLY the following in the .htaccess file (but still didnt work):

SetOutputFilter DEFLATE
SetEnvIfNoCase Request_URI \.odp$ no-gzip dont-vary

Edited by Eric_9

2
Contributors
1
Reply
12
Views
3 Years
Discussion Span
Last Post by rtrethewey
0

It looks like you might have copied a tutorial somewhere that included 3 different ways of enabling gzip. I'd be surprised if that worked.

Deleting the .htaccess file would certainly disable gzip. If that caused a problem, then just delete all of the code you posted here.

Generally, it's a good idea to enable gzip to speed up your site for users, but it can sometimes cause performance problems if the server is busy.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.