0

We have a third party web host who designs our website and hosts it. They use templates and "tokens". What we do is upload our news articles as .txt documents. All of a sudden, our dashes and hyphens show up as question marks. Any ideas?

Thanks,

Heather

6
Contributors
9
Replies
10
Views
10 Years
Discussion Span
Last Post by MidiMagic
0

We use simple text and the default font is courier. I do know that there was a "front" folder that was deleted and then we started having the issues. We put the folder back. The host said that the folder is usually empty and that deleting it and putting it back did not cause the issue. However, I am at the mercy of their $100 / hour tech support because I am a net admin - not a developer or designer.

Here is our site: http://www.thelancasternews.com

0

Are you using MS Word to create these .txt files? If so, I think you are encoding your text differently to what their web pages are using. If you want, try using notepad (or else, just make sure you use UTF-8).

0

yes, use notepad

the problem may be that you are making windows text files and the server expects UNIX text files

0

Aren't windows & unix text files essentially the same except for their line endings? (Just curious)

0

I do a lot of work using PHP and MySQL and i notice that if i open the readme files (created on unix type systems) hey often have wierd characters like squares or accents

0

The trouble is that there are several versions of different characters in Word. I would suggest you change some settings:

- Go into the Word spellchecker and turn off the functions whcih make smart quotes and long hyphens.

- Make sure the server, your computer's default, and word's default are all the same character set.

- The only character in this area which is universally defined is the minus sign. Real hyphens and long hypens are in extended character sets.

- If you have trouble after that, choose the US ASCII character set in the editor. Your text won't be as pretty, but it works anywhere.

0

If you stil have trouble, try making plain text files with edit under cmd. This will a plain ascii file without extended characters.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.