0

My 2005 PowerBook G4, 1.25GHz with a Fujitsu HD has been funny for a while. I flattened it and reinstalled OSX 10.3.4, didn't improve things so bought Leopard. Wouldn't install. Now won't open at all, just get grey screen, Apple logo and revolving clockface. Makes clicking sounds but does nothing. Is my HD dead? I've got my data backed up but is there anything I can do?

You guys all know tons more than me and I'm completely stumped. I'm currently having to use a PC 24/7 but I miss my baby Mac. Please can someone help?:(

Cheers,

Andalublue

2
Contributors
6
Replies
7
Views
9 Years
Discussion Span
Last Post by steven woodman
0

Hi Guys,

Just tried something different.

Tried a hard reboot with the Leopard installer disc. Held down the C key and the installer launched. Selected destination, clicked Install, skipped the DVD check as it did it the last time I tried it. Up came the Installing screen saying "Installing Mac OSX on the volume Macintosh HD" and below the moving blue and white bar it says "Time remaining: Calculating..."

After 3 minutes the blue and white moving pole changed to the progress bar, still says "Time Remaining: Calculating..." Intermittent clicking sounds. Also the sound of the DVD operating.

After another 3 minutes, with the blue on the progress bar having reach only about 1/20th of the way from left to right I get a box come up saying "You need to restart your computer. Hold down the Power button for several seconds or press the Restart button." in 4 languages. That's as far I seem to be able to get. I can hear the fan whirring but no other activity seems to be going on inside.

I reckon it must be an HD problem, no?

Any advice greatly appreciated.

Andalu

0

Yes, you may be caorrect there. The clicking is usually caused by a harddrive error. If you have another computer you can take out that hdd and run a disc check. There are many utilities for checking discs out there.

Hope that helps.

0

Steve, it does help. But how would I connect my dismantled HD to another computer (I've got an HP Laptop) to do that check?

I'm going to Google to find a disc checking utility right now.

Thanks!

Andalu

0

Dear Steve,

Thanks for this. I think I've got to the bottom of the problem. Yes, the HDD is dead. I installed OSX onto my Lacie external drive and then used that as my startup disc. I checked the disc utility and my Fujitsu HD in my PowerBook has a fatal error. I feared as much. I'm going to have it replaced. Fortunately, I backed up my data not so long ago and so I've lost nothing.

Thanks so much for your advice.

Andalu

0

Glad to hear you backed up your data. thats always a good idea.

Well hdd problems are an easy and relatively cheap fix, it could be worse.

Good luck

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.