0

I'm desperate for some help.

I removed spyware trojans, etc, I've seen similar solutions and problems everwhere but can't seem to fix mine. PLEASE help.

My background is either white or grey. It hides my desktop background picture.

It is temporarily visible when starting up/shutting down.

If I mess with the high contrast settings(I've been messing with everything trying to fix it) it gives me Cannot Find file:///C:/WINDOWS/WEB/desktop.html

Here's the thing thats throwing me off. Everyone says go to the desktop tab. And uncheck yadda yada...well...I either really can't find my desktop tab(wich I've looked everywhere and followed instructions as to where it should be) or I do not have one.

So....what do I do?

3
Contributors
22
Replies
23
Views
10 Years
Discussion Span
Last Post by batmandar
0

that file... you've had your desktop hijacked. To see some of these files you have to disabvle view protections for them.... but no matter, cos in this case i think..think...that if you rclick in a clear spot on your desktop, go properties > desktop > customise desktop >web and then delete any entries there, you should then be clear of your problem. Pls come back if this solves it. or doesn't.. :)

0

..to see those hidden 7/or protected files go control panel > folder options > view and select Show hidden files and folders, and uncheck Hide protected operating system files.... Yes, apply, and outta there. But i advise you to NOT leave the latter exposed - system mayhem lies down that road, so once sorted go back in and RE-HIDE those prot. op sys files.
That file u mentioned is the problem.... you can safely delete it...

0

I don't have "folder options" in control panel. I have appearance/themes, network/internet, add/remove programs,sound/speech/audio, performace/maintinence, printer, user accounts, date/regional time, accessibility options, and security

0

You could always go to Start --> Search then click onm All Files or Folders then click on the little down arrow next to More Advanced Options and check Search hidden Files and Folders. then search for desktop.html and delete all instances and then restart computer. This should do it.

0

Ha.. the world is an amazing place. The very first time i choose to show that particular path to folder options instead of the usual way i lead folks to it.... Anyway, ditch category view for your folders, at least for control panel - it sucks. Open an explorer window, select control panel in the left pane, maybe click folders tab, and select classic view. Then go up to View and select Show details. Now u can see folder options.
Ok, you've done that - good. But i NEVER take that path to control panel.. i use the start menu pane.
Make sure the start menu is NOT in Classic view [rclick Start button, select Properties and choose Start menu, Apply, OK] . Good, now press Start and rclick in an area where nothing highlights eg the in the blank bit of head or tail of the pane, click Properties [heh!, it's just another route to the same window you just used :) ...good ole M$ for fattening an OS], select Start menu and Customise, Advanced. Choose to display control panel as a menu. I use the same setting for My Docs and My Computer. Apply and Ok your way out.
So now to get Control Panel, click Start, hover pointer over Control Panel, and in the menu u should see Folder Options.
Course, in an explorer window u could always go Tools > Folder Options... :D
Now... what was the question? oh , yeah... go back to my earlier post that you were following.....
Cheers...

0

well. Those options in folder options were already the way you wanted them...so I checked the hide operationg systems one coz it WAS unchecked...and for some reason, now I can't rclick on my desktop at all. o.0

0

delete all instances as in EVERYTHING it finds?

"in this case i think..think...that if you rclick in a clear spot on your desktop, go properties > desktop > customise desktop >web and then delete any entries there, you should then be clear of your problem" // well, yes, delete any entries that you do not use to create desktop backgrounds [any entries in there can be used to create a background - you add webpages you wish to use// normally it is empty]
I take it that you got your desktop rclick back?

0

yes it got the rclick back when I restarted. However, the whole reason I can't fix this problem is I don't have a desktop tab in the properties menu otherwise it would've been fixed already... =( I can't get it to show up with hidden files either...

0

Go Start > run, type regedit in the box and press OK.
Navigate to this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Open the System subkey by lclicking it [it highlights]. Check to see if there is a Dword in the right pane with a name something like NoDispDsktopPage.... if it exists and has a value of 1, then either change the value to 0 or delete the actual Dword.
Depending on what put the Dword there, there may be a corresponding Dword in HKLM hive also. Change that one's value to zero or delete it also.
NOTE To delete the Dword, just highlight it and press delete key.
If you are unsure about this, just highlight System subkey as before, and export it. Post the notepad file here.

0

Go Start > run, type regedit in the box and press OK.
Navigate to this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Open the System subkey by lclicking it [it highlights]. Check to see if there is a Dword in the right pane with a name something like NoDispDsktopPage.... if it exists and has a value of 1, then either change the value to 0 or delete the actual Dword.
Depending on what put the Dword there, there may be a corresponding Dword in HKLM hive also. Change that one's value to zero or delete it also.
NOTE To delete the Dword, just highlight it and press delete key.
If you are unsure about this, just highlight System subkey as before, and export it. Post the notepad file here.

Oh my gosh you've done it! I have the desktop tab...now that it's ALMOST fixed....it won't let me choose a different background image and the blue is still on top of the background, the list of background images is greyed out I cn't scroll and so is the browse option.

0

OK. that policies sub-key again... above system you should see ActiveDesktop.... check its entries - delete any Dword other than default. The entry that is stopping you is prob called NoChangingWallpaper - as i said, delete it or change its value to zero.

0

OK. that policies sub-key again... above system you should see ActiveDesktop.... check its entries - delete any Dword other than default. The entry that is stopping you is prob called NoChangingWallpaper - as i said, delete it or change its value to zero.

That didn't change anything, but the no displaying custom wallpaper was in there and no html wallpaper deleted everything but the default, but it's still greyed out =/

0

ok, just in case, go to the same subkey under HKLM and repeat actions. [you have to reboot after some of these changes, cos the entries have already been read by windows, and it must be forced to take another look..]

0

ok, just in case, go to the same subkey under HKLM and repeat actions. [you have to reboot after some of these changes, cos the entries have already been read by windows, and it must be forced to take another look..]

Tried still no go. Under the explorer tab there is a DWORD that says No active desktop and no active desktop changes, also force active desktop, would these have anything to do with it?

0

Very likely... but just so we don't do too much damage, ok any damage, would you please export that subkey and post it here?
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Lclick explorer in the left pane to highlight it, go files, export, name the file bungdesktop and save as .txt.
Do the same for the \system subkey also [you choose the filename this time.. :)].

0

Very likely... but just so we don't do too much damage, ok any damage, would you please export that subkey and post it here?
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Lclick explorer in the left pane to highlight it, go files, export, name the file bungdesktop and save as .txt.
Do the same for the \system subkey also [you choose the filename this time.. :)].

Here you go. :cheesy:

Attachments
Key Name:          HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Class Name:        <NO CLASS>

Last Write Time:   12/24/2005 - 2:46 PM

Value 0

  Name:            NoDriveTypeAutoRun

  Type:            REG_DWORD

  Data:            0x91



Value 1

  Name:            NoActiveDesktopChanges

  Type:            REG_DWORD

  Data:            0x1



Value 2

  Name:            NoActiveDesktop

  Type:            REG_DWORD

  Data:            0x0



Value 3

  Name:            ClassicShell

  Type:            REG_DWORD

  Data:            0x0



Value 4

  Name:            ForceActiveDesktopOn

  Type:            REG_DWORD

  Data:            0x1
Key Name:          HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Class Name:        <NO CLASS>

Last Write Time:   2/7/2007 - 5:39 PM

Value 0

  Name:            Wallpaper

  Type:            REG_SZ

  Data:
0

Key Name: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
-----Delete this DWord:- Name: Wallpaper


Key Name: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
-----Delete these DWords:-
Name: NoActiveDesktopChanges
Name: NoActiveDesktop
Name: ForceActiveDesktopOn

And that should be the end of the problem. They are very likely not duplicated there, but check the corresponding subkeys under HKLM also, and duplicat actions. I imagine the bug acted on a current user basis.

0

Key Name: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
-----Delete this DWord:- Name: Wallpaper


Key Name: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
-----Delete these DWords:-
Name: NoActiveDesktopChanges
Name: NoActiveDesktop
Name: ForceActiveDesktopOn

And that should be the end of the problem. They are very likely not duplicated there, but check the corresponding subkeys under HKLM also, and duplicat actions. I imagine the bug acted on a current user basis.

Yes that fixed it. However. When I change the background and hit apply, it gives me an error box "Cannot find 'file:///C:/WINDOWS/Web/desktop.html' make sure the path or internet address is correct."

And the backgound does not change.

Darn...so close :sad:

0

Hmmm, closer n closer... desktop.html. Okay, you could do a search in registry for that name cos it is not a windows file. I think it will turn up under this key...
HKLM\Software\Microsoft\Windows\CurrentVersion\Run
where you will find that pathname C:\WINDOWS\Web\desktop.html - delete the Dword. Could be under HKCU. May be in an internet explorer\desktop subkey also.... feel free and safe to delete the Name containing that pathname in those subkeys.
Check also to see if is revealed in the Web desktop settings for your display now.

0

Hmmm, closer n closer... desktop.html. Okay, you could do a search in registry for that name cos it is not a windows file. I think it will turn up under this key...
HKLM\Software\Microsoft\Windows\CurrentVersion\Run
where you will find that pathname C:\WINDOWS\Web\desktop.html - delete the Dword. Could be under HKCU. May be in an internet explorer\desktop subkey also.... feel free and safe to delete the Name containing that pathname in those subkeys.
Check also to see if is revealed in the Web desktop settings for your display now.

Deleted them, but...when trying to change wallpaper(again) it shows up as an explorer window for files and folders, it says its located at "C:\Documents and Settings\Owner\Application Data\Microsoft" but I can click on the files and everything, I have no idea what that means hehe

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.