0

(Note: Please be patient with me as I still know next to nothing about Linux)

I prefer KDE, but I also like Firefox. Firefox is what got me interested in open-source in the first place. The problem is that Firefox is a GNOME application, and is designed to run in GNOME. Most of the side-effects of this (such as non-standard menus, different dialogue boxes, etc), I don't mind. In fact, there's really only one thing that bothers me, and that that Firefox wants to open everything in what GNOME is set to open it in.

This means that I must manually open all downloaded files in order to use them. Normally, I could do this without a great deal of additional hassle by right-clicking the download and selecting "Open Containing Folder", however, this opens the folder in Nautilus.

In order to get the file associations to work I had to give up and use Konqueror, but I didn't like working with Konqueror's limited feature set, and I quickly became frusterated with it, especially on pages with a great deal of ads, which I had no adblock for.

I then decided I would rather not have KDE than not have Firefox, so I switched to GNOME, however, I am now growing tired of GNOME. No offense, but I don't think it's as stable as it tends to open tiny windows for system tray applications, causing me to have to terminate them, and about 10% of the time it starts up, nautilus crashes. I don't like being unable to modify the applications menu, and I need to be able to set HTML pages as wallpaper for various reasons, something that I cannot do with GNOME, at least, not to my knowledge.

I managed to fix the file extensions by booting into GNOME and setting them to what I wanted in KDE. This made GNOME unusable, but with this, I wouldn't need it.

This has successfully enabled me to get Firefox to recognize file types, but I have one problem left. Firefox is still performing the "Open Containing Folder" command in Nautilus. I have an idea on how to fix it, but I need some help from an experienced Linux user.

I noticed that the "bin" folder contains various scripts for launching applications. I figured that Firefox must be using this in some say, so I created a script called "Nautilus" and set it to open Konqueror. This partially worked, as the "Open Containing Folder" command did open in Konqueror, but it didn't open the actual folder, and loaded Konqueror's homepage instead. I want to know how to write a proper script to do what I want to do. Can anyone help?

3
Contributors
4
Replies
6
Views
12 Years
Discussion Span
Last Post by drauh
0

>>The problem is that Firefox is a GNOME application, and is designed to run in GNOME
Oops! I didn't know this, so I installed Firefox on several distros, and it works flawlessly in KDE.... :cheesy:

0

>>The problem is that Firefox is a GNOME application, and is designed to run in GNOME
Oops! I didn't know this, so I installed Firefox on several distros, and it works flawlessly in KDE.... :cheesy:

wow. that was a truly useless response.

fwiw, i've had both happen. both accounts have kde as their default window managers. on one account, firefox seems to launch konqueror just fine. but the other runs into the same problem of launching nautilus. it's bugging the hell out of me (actually, out of my user -- i use mac os x where things just work™). i run fedora core 4.

0

which bin directory are you speaking of? /usr/bin?

anyway, from using the --help option to konqueror:

--select  For URLs that point to files, opens the directory 
          and selects the file, instead of opening the actual file

so, doing

konqueror --select [i]filepath[/i]

will do it, i.e. in your script (assuming sh/ksh/bash), do

konqueror --select $1

i add --silent to quieten it down, or you can redirect output to /dev/null. so, my script looks like this:

#!/bin/sh
/usr/bin/konqueror --silent --select $1
0

i add --silent to quieten it down, or you can redirect output to /dev/null. so, my script looks like this:

#!/bin/sh
/usr/bin/konqueror --silent --select $1

ah, well, i played around a bit. firefox uses the URI of the enclosing folder as an argument. so, suppose i downloaded the file to /home/myself/Desktop/goodstuff.mp3, it uses file:///home/myself/Desktop as the argument. with that in mind, change the script to:

#!/bin/sh
/usr/bin/konqueror --silent $1

and copy it to /usr/bin/nautilus -- et voila.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.