0

I am building a website locally and I have a crazy problem. If I enter a path to the file in my browser like:

file:///home/jcrider/public_html/site/assets/5182/sound/r_Fantasia_Chopin_44.mp3

It will play the mp3, but when I try to run it through localhost like:

http://localhost/site/assets/5182/sound/r_Fantasia_Chopin_44.mp3

It does nothing. It did work once, but I haven't been able to get it to work again. I tried restarting apache and still nothing. I am really stumped on this one and pretty new to Linux (running Ubuntu 9.10) so it could be something dumb that I am overlooking.

3
Contributors
4
Replies
5
Views
7 Years
Discussion Span
Last Post by xylude
0

Dang, nevermind. Just was having some weird issue when I booted up. Logged out and back in and everything is cool now.

Edit: Actually it's not cool. It only seems to want to play the file once through localhost. After that it just keeps saying 'loading' but nothing ever happens.

Edited by xylude: n/a

0

Hi xylude,
What about the browser ? Did you try closing and reopening the browser ? There must be some media plugin which was playing the mp3 earlier. What if the media plugin got stuck playing the mp3 the first time and subsequent requests were queued by the plugin ?

0

Hello,

The best advice is "Look at the logs". Check and see what your httpd access and error logs show for the request. That will point you in the right direction to solve it.

0

Thanks guys, I found the problem - it was Firefox for Linux acting wierd. Tried it in Opera and on some other OS's and everything was fine. Sorry for the trouble.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.