0

I have been using kali linux for a wile now on my mini laptop. I am a developer and would like to start developing in nasm. The problem is when I try to download nasm I use this command:

apt-get install nasm

It gives an error that there isnt such a package.

I have also tried:

apt-cache policy nasm

It also give that error (I am not sure what the precise error code is as I am posting this from a different computer, but it is basicly that there isnt a package named nasm)

I also tried to install g-edit, it gives the same error. Same with libre office.
How do I fix this?

4
Contributors
4
Replies
25
Views
4 Years
Discussion Span
Last Post by JasonHippy
0

Have you updated your package list using:

apt-get update

It might be that it isn't on your current one, and so a simple refresh of it shall do the trick. It depends when you last updated it, and when it was added (or removed in some cases).

Edited by Octet

0

OK, sounds like it could be a DNS related issue.
This thread in the official kali forum might help you:
http://www.kalilinux.net/community/threads/installing-packages.61/

In it, the OP reports being unable to install any packages from the official repos via apt.
Turns out their DNS settings were causing the problem. Some way down the first page the OP posts the following as the solution to their problem:

Ok we have success,done a bit of googling and found some info on editing the etc/resolv.conf file. Changed the nameserver from my routers default address to googles 8.8.8.8,ran commands and hey presto we have lift off.. Thanks for everything...

So checking/changing your DNS settings might solve your problem!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.