0

So this is a new installation of Fedora. I'd not used Fedora in many months prior to this point. I had Fedora 25. However the Wifi on this machine is quite troublesome.

There are times when the connection will stop completely. I will try to load a webpage and the connection just dropped. It tries to reconnect but sometimes it doesn't even show nearby Wifi APs.

It just keeps cycling and never shows anything. I am very frustrated.

2
Contributors
6
Replies
24
Views
1 Month
Discussion Span
Last Post by rproffitt
2

That's one deep rabbit hole. Read and think over the discussion at https://bugzilla.redhat.com/show_bug.cgi?id=1409631

Notice this?

Some HP notebooks using this rtl8188ee hardware module can't get AP scan results with pin-based interrupts mode, enabling MSI interrupts mode could fix it.

Now you might complain that this isn't exactly your version but go down that rabbit hole to find that make, model of the PC and WiFi hardware is needed to see if anyone has a fix.

Hope you remembered to plot a return path to the surface.

1

Hmmm... I just installed some updates after connecting via ethernet. The Wifi seems to be working now. Will check back if the problems persists.

Edited by Curious Gorge

Votes + Comments
Thanks for the check in. Always nice to read updates.
0

So its been a few days... the WiFi seems intermittent again. I have indeed checked out the link you sent me and tried the solution but it doesn't seem to work. I then tried comment #27's solution, some command with tcdump which printed out almost exactly what comment #37 got.

I'm not sure where to go from here...

0

Here's my exit. Not that I'm abandoning you but want to share how I fixed a machine with WiFi support issues when I couldn't change to another distro. FIX! I plugged in another WiFi USB stick and that worked. I disabled the onboard and moved to the next problem.

Now I understand some may gripe about such a fix but here these sticks are from 8 to 20ish bucks and plentiful. Here is the USA and Amazon is quick to deliver so I have that going for me.

0

Oh yeah, I'd thought of that. I have only 3 usb ports on this machine, one of which is always in use by a unifying receiver for my mouse. It would be nice to avoid plugging in another device leaving just one port for anything else that I need. I have an extra usb dongle lying around, I may try that. Its pretty frustrating that the Fedora crew can't fix this bug. I don't want to toss around insults but to call yourself state of the art and this bug exists for 6 versions??? Come on.

0

Toss away.... Anyhow, one of the reasons for Linux is open source. There are new to Linux folk that think that all bugs shall be fixed by the company or group. This is not how it works. You either report the bug and hope someone nails it or dig in yourself to fix it and if you fix it contribute to the effort.

I've never had the time to dig in and fix more than say a configuration file to get something to work or contribute hardware to a developer but my point here is that Linux is different from Windows when it comes to bugs like this.

Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.