0

Hi I am new to linux and ubuntu and have installed ubuntu on a machine so I can muck around with it. I have been trying to install wine as well. On the wine website it says to:

"First, open a terminal window. Then add the repository's key to your system's list of trusted APT keys by copy and pasting the following:
wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
Next, add the repository to your system's list of APT sources:
For Ubuntu Feisty (7.04):
sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/feisty.list -O /etc/apt/sources.list.d/winehq.list
For Ubuntu Edgy (6.10):
sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/edgy.list -O /etc/apt/sources.list.d/winehq.list
For Ubuntu Dapper (6.06):
sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/dapper.list -O /etc/apt/sources.list.d/winehq.list"


I have tried doing that for my ubuntu vs which is 6.10 but the problem is that when i do the "wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -" command it says there is no such thing as apt-key.

Any pointers on this? I am new to all this and may be missing something as the only linux command I know in the terminal is "exit".
thanks in advanced

2
Contributors
5
Replies
6
Views
10 Years
Discussion Span
Last Post by Don Gino
0

If /usr/bin/apt-key doesn't exist, something is definitely wrong. I would definitely reinstall Debian's apt tools if apt-key isn't on the hard disk.

0

Are you sure that the file doesn't exist? To test it, try running the following command:

# cd /usr/bin/apt-key

If it says "No such file or directory", then it doesn't exist (or at least not in that location). If it says "Not a directory", then it does indeed exist.

>How would I go about doing that?
Download the .deb file that matches your processor architechture:
http://packages.debian.org/stable/admin/apt

Then to install the .deb file, run this on the terminal:

# sudo dpkg -i ~/Desktop/apt.deb

Where ~/Desktop is the path of the file, and apt.deb is the exact name of the file that you downloaded (it'll have a version number after it).

0

Ive got the file on the desktop and its called "apt_0.6.46.4-0.1_i386.deb". I tried different combinations of paths and file names and it says it cant find it.

would it be like this:

sudo dpkg -i ~/home/myname/Desktop/apt.apt_0.6.46.4-0.1_i386.deb

thanks. As you can see I im linux illiterate :P. Ive grown up on dos and windows all my life

thanks

0

I think i found the problem. The vs of ubuntu is 4.10. All along I thought I had 6.10

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.