Hello,

I'm trying to install 10G on Suse 9 Kernel 2.6.

Following the tutorial on Oracle site or the product manual, the memory setting must be done on /etc/SYSCTL.CONF. However, this file doesn't exist on Suse and I don't know where I will put the parameters!

Did someone tell me what I need to do to set shmmax, shmmin and others permanently on Suse?

All help is very welcomed.

Thanks,

Eduardo :cry:

You should just be able to create the file, and SuSE should read it.

My experience has been that you only have sysctl.conf on your system if you needed to tune some kind of kernel setting at boot time.

Thx Alex. I'll try it.
By the way, ask me when you need some help!
Eduardo

Hey, Eduardo, did you get this issue resolved. I am starting an install of Oracle 9i, with the exact same question. Also, some parameters in the Installation Release Notes don't even exist in my SUSE Linux 9 Enterprise environment.

Based on what I read here, I must create the /etc/sysctl.conf file and add the parameters Oracle requests, period. If anyone has any experience doing an Oracle installation on SLE9, and have a few pointers for me, please don't hesitate to email or post your comment on here.

Thanks.

YES!

create /etc/sysctl.conf if it doesnt exist!


is mandatory for adjusting memory allocations for Oracle 9i/10g.

Is the equivalent of /etc/system on Solaris systems.

enjoy.

Put in a line
kernel.shmmax=somebits
<SNIPPED URL>