I have an old 366 MHz clamshell Indigo iBook, and it's got OS 10.3.9 on it. There's a Firewire port on this clamshell, but no DVD, so to try and put OS 10.4 on it I wanted to use Target Mode, which seems to be pretty straight forward, and use a second computer's DVD drive.

But so far I haven't been able to get the source computer's hard drive icon (I tried a white square G3 iBook and a Quicksilver G4, both running 10.4.4) to appear on the desktop of the destination computer, the clamshell.
I zapped the PRAM before doing this, and along with other instructions on the procedure, found this to be the clearest:


I can get the source computer to be in Target Mode no problem, and I'm using a new Firewire cable, although new doesn't mean functional. I have no other cable to try. The clamshell has had all the updates you can download for 10.3.9.

So far, I can't get the other computer's icons to come up on the clamshell.
Any ideas where I'm screwing up?

I ended up borrowing another Firewire cable and that worked.
So the culprit ended up being a defective brand new cable.