In my home, my computer is the only one with an Internet connection.
Last week I bought the D-Link Wireless DIR-300 Router so I could use the spare computer in the other room.

The first time I installed the software for the router I only followed the wizard.
Then I realised more needed to be on through the Internet (192.168.0.1)
I didn't really entirely understand what I needed to do so i followed the manual.
The Internet was working fine on the computer I was on BUT the second computer received nothing.

I got to the stage where it said my computer needed to be restarted in order for the new hardware to work. And that's when things went wrong.

-Computer died on me a few days but came back to life-

The second time I decided to check the settings of the router through the website (92.168.0.1). I was looking at the LAN settings and saw the box: Router IP Address. (attachments)
I thought I was suppose to change the IP address so I did (Was I suppose to or leave it as default?) & I also unchecked the 'Enable DHCP Server' =\

NOW whenever the router is connected to the modem, it only gives off 'No or Limited Connection' and I simply don't know what to do now.

If you disabled the DHCP server on your router the windows network connection will show you 'No or limited connection'. This is because your network interface (on the computer ) is set to "obtain the IP address automatically. The DHCP does this automatic IP addressing.

I don't know if I understand your description correctlly.

Try open your network connections, and see what IP address you have on your Local Area connection.
Do you remember to what IP you changed the "router IP address"??

So I was suppose to leave the DHCP thing alone, right?

Right now, I'm only connected with the modem and I checked my ip. It's 124.186.7.138

And I'm pretty sure that's what I changed the default IP on the router to.

My main problems are really:
- Getting the router to function normally with the modem it's connected to

AND

- Getting the 2nd computer to receive the signals from the router so it can go on the Internet ~

Yes. If you don't want to manage your local IPs manually, check the DHCP enabled.

I suggest that you have modem for dial up which is connected to your routers WAN (ethernet port). This is your public internet connection.

When you say you are connected with modem, I suggest that you are connected with your PC directly to the modems ethernet port. (here you get valid data from your modem)

If so, make note about the IP configuration you get from the modem.
The IP address, the gateway.

This should be set up on your routers WAN configuration. (check the D-link config for this section).
Think about it as the WAN is the public (internet) gate to yuor router, and the LAN the private gate (for example 192.168.0.1).

If your (public) IP is 124.186.7.138, this address should be as the routers WAN gate.

Make printscreen about the routers WAN config section.

This Configuration is for U.A.E..if u r out of U.A.E u should change VPI and VCI.....

Ah thank you very much!
But unsure what the U.A.E & VPI & VCI stand for...
I've been busy lately so I've kinda just dumped my router to one side~

U.A.E mean United Arabs Emirates.This is one of the country. VPI mean Virtual Path Identifier and VCI mean Virtual Channel Identifier.VPI and VCI are not equal to all country so u have to get these number from ur country.IN U.A.E, VPI = 0 and VCI = 50.