hi all, i just started doing some uva problems....
first question was 3n+1 problem....
for those who don't know what it is..here is the question...

The Problem

Consider the following algorithm:


1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then tex2html_wrap_inline44

5. else tex2html_wrap_inline46

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no operation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

i coded the following but doesn work in time(2 sec limit)...
code is as follows :

import java.util.HashMap;
import java.util.Map;

public class ThreeNPlusOne {
    public static void main(String[]args){
        Scanner s = new Scanner(System.in);
        HashMap<Integer, Integer> mem = new HashMap<Integer, Integer>();
        mem.put(1, 1);
        while(s.hasNext()){
            int min = s.nextInt(), max = s.nextInt(), maxc = 1;
            for(int i = min; i <= max; ++i){
                int tmp = i, cnt = 0;
                while(tmp != 1){
                    if((tmp & 1) == 1)
                       tmp = tmp * 3 + 1;
                    else tmp /= 2;
                    cnt++;
                    if(mem.containsKey(tmp)){
                        mem.put(i, cnt + mem.get(tmp));
                        maxc = Math.max(maxc, cnt + mem.get(tmp));
                        break;
                    }
                }
                if(mem.containsKey(i) == false){
                    mem.put(i, cnt);
                    maxc = Math.max(maxc, cnt);
                }
            }
            System.out.println(min + " " + max + " " + maxc);
        }
    }
}

any optimizations suggested are appreciated...
thanks in advance....

Recommended Answers

All 4 Replies

In c++ , recursively, not tested.

void printSeq(int num)
{
    cout<<num<<" ";
    if(num == 1 ) return;
  
   if( num & 1) //if odd
         num = num*3+1;

   else num /=2;

   printSeq(num);
}

Maybe you found a counterexample.

Maybe you found a counterexample.

If its at me then, for what?

@OP : you are way over complicating your code. Start fresh. Look
at the c++ code, convert it using for loops in java if you want.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.