0

I noticed that my backup of my 2005 sql server didn't work over the weekend. I don't really know where to start as I haven't dealt much with servers. But I can tell you this....

SQL Server agent has a big red circle through it for not working on the server. Should I restart it?

My error log only states sql server agent terminiated (normally)

And the local host service is not running.

I have my domain server and then another windows 2003 r2 server with sql2005 on it. The domain is working. Should I restart something on my sql server?

Please help and thank you.

2
Contributors
16
Replies
17
Views
8 Years
Discussion Span
Last Post by pace59
0

That isn't really enough information to indicate what caused the backup to fail. Look through your SQL Server Error Logs and your Window's Error Logs to see if you can find more detail. PASTE the EXACT error messages as seen on your server to the forum, each in its own [ code ] block.

0

My SQL server error log messages are:

2/11 (130) SQLAgent$xxxx stopping because of windows shutdown
2/11 (165) ODBC Error: 0, Driver's SQLAllcoHandle on SQL_HANDLE_ENV failed (SQLSTATE IM004)
2/11 (382) Logon to server failed (SaveAllSchedules)
2/11 (359) The local host server is not running
2/11 (098) SQL Server Agent terminated (normally)


My windows error was SQLVDI: Cleanup Desc=Release (ClientAliveMutex), ErrorCode=(288)Attempt to release mutex not owned by caller. Process=2620. Thread=416.

**************************************************

Should I first right click on the SQL server agent and restart that?

0

Start -- Run -- "services.msc" and hit enter. Make sure all of the SQL Server Services are running that have their Startup Type to automatic. If the services are failing to start on boot you probably have a bigger problem and will encounter this each time you reboot. There must be more logs in the windows event log to indicate what is going on....

Have you changed a password on the machine recently, or changed the startup user for the processes?

Also i'm assuming between the (130) and (165) logs the server completed a reboot, and isn't hanging in the pending state of failing to go down for a reboot? These logs should be timestamped to the minute...

0

All of my services are running that are set to automatic. the only thing that wasn't running that was set to manual was the directory helper and I noticed that the sql server agent wasn't running. But those were both set to manual.

For my windows log warnings I have replication of license failed because failed to contact the license logging service on the domain.

My last successful backup was 2/11 in the a.m. The only error i am getting at all the same time at 12:46am is the error listed above with the SQLVDI, etc. Attempt to release mutex not owned by caller.

does that help at all?

0

2/11 (165) ODBC Error: 0, Driver's SQLAllcoHandle on SQL_HANDLE_ENV failed (SQLSTATE IM004)

That shows up on google associated with Oracle issues on SQL Server, are you connecting to an Oracle DB?

0

Should I just shut the entire server down and restart and see what happends? i would not shut my domain down at this time.

0

Yeah... thats what I would do. With problems like these I have found they are solvable without doing a reboot but take an hour or two where as a reboot fixed it naturally in a few minutes.

0

Ok I rebooted the server. The SQL server agent still has a red circle with x through it meaning it isn't on. In the services, should I change this from manual to automatic. Is that the main sql server, and should it be on all the time? I am soo new to this.

I checked the sql server log after I brought the server back up and see the following:
Error 18456 severity 14 state 14.....any ideas

Login failed for user "xxx" (client: local machine)

0

Are the error codes, severity, and state correct? From a typo in your earlier post on log messages I assume that you are hand-typing these messages and not pasting them.

I can find very little information for state 14 with that error code, but either way this is going to be some sort of user rights issue.

Please provide all of the error messages, and please paste them. (SQL Server Log, Windows Event Log, Anything)

0

Logon Error: 18456, Severity: 14, State: 16

SQL Server is terminating because of a system shutdown.

The connection has been lost with microsoft Distributed Transaction Coordinator (MS DTC),

Error: 17054, Severity: 16, State: 1.

The current event was not reported to the Windows Events log.

Operating System error=1717(The interface is unknown.).

Service Broker manager has shut down.

.NET Framework runtime has been stopped.

SQL Trace was stopped due to server shutdown. TraceID-'1'.

The SQL Network Interface library could not deregister the Service Principal Name (SPN) for the SQL Server service. Error: 0x45b, state:4.

That's the errors I received from the SQL server the first day i had a problem. I found the problem started on 2/11. These are the messages from where the problem started to occur. These errors occurred all at the same time.

**********************************************

SQLVDI: Loc=CVDS::Cleanup. Desc=Release(ClientAliveMutex). ErrorCode=(288)Attempt to release mutex not owned by caller.
. Process=2620. Thread=7588. Client. Instance=xxxx. VD=.


Login failed for user 'xx'. [CLIENT: <local machine>]


These are the ones I received from windows.

***************************************************

0

State 16 means that the default database for that user is not accessible. I'm assuming since the login is "xx" that it is actually "sa" so check the default database of that user. If it does not exist then change it to a database that does exist. If it does exist then make sure sa has access to that database.

0

My sql database I want sa to have access to. User sa can log into my database that isn't being backed up, so I am sorry but I am not following.

How about the backup? Any ideas what might have happened there or suggestions?

i appreciate that you are giving me.

0

I dont know what to say, this is hard without being able to physically get at the setup and experiement. Read these two URLs as they cover a number of problems, same error codes as yourself, and possible solutions:

http://blogs.msdn.com/sql_protocols/archive/2005/12/22/506607.aspx

and

http://blogs.msdn.com/sql_protocols/archive/2005/12/22/506607.aspx

If you do find the answer please post it back here, if not then let me know and I'll take a look at this in more detail when I am in the office tomorrow.

0

Regarding the sa account being able to log on, it is still throwing a security error and the backup service needs to connect to the SQL Server to perform the database backup, it doesn't do a hot-copy of the .mdf and .ldf files.

That is why I still think this is a security related issue to one of the SQL Services. I could be wrong, but its my hunch.

0

The backup is working now by restarting the SQL Server Agent.

Now I am trying to solve the windows error:


SQLVDI: Loc=CVDS::Cleanup. Desc=Release(ClientAliveMutex). ErrorCode=(288)Attempt to release mutex not owned by caller.
. Process=2636. Thread=4384. Client. Instance= . VD=.

I am thinking that this may require a hotfix/patch. Not sure though.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.