0

Okay, not new to MySQL, or PHP, but I'm really lost on this one. I have a query (simple one really) that is supposed to return the requested values from a database. I've tested the query with MySQL direct and it works fine, but when used via the web interface, it chokes and doesn't get a valid result resource.

I don't understand how a valid query can work with MySQL directly but not with the web interface. I've added the query below:

SELECT GUID, FirstName, LastName, Address, Address1, City, State, Zip, Phone, Email, Company, Remove FROM databasename WHERE GUID = '$id'

$id would of course be a POSTed variable. I've also tried this using "SELECT * from databasename" and it also fails for the same reason. Of course, my first thought was something simple so I pasted a working query from another function and it also failed. Nothing is any different for the connection as it's the only one used. And yes, all the column names are correct.

What am I missing?

thx,
Plenty

4
Contributors
5
Replies
6
Views
12 Years
Discussion Span
Last Post by pgroover
0

perhaps you are not logged in with the correct username/password combination

if you do have a correct user name/password then...
maybe the one you have doesn't have access to SELECT statments on that database and/or table

try doing this...

<?
$server = "localhost";
mysql_connect ($server, $user, $password) or die ('I cannot connect to the database because: ' . mysql_error());

mysql_select_db ($database) or die ("cannot connect to the datbase");

$result = mysql_query("SELECT * FROM databasename");
if ($result == 0)
{
   echo("<b>Error " . mysql_errno() . ": " . mysql_error() . "</b>");
}
else
{
    echo "the query worked!";
}

hopefully the error message generated gives you enough information to solve your problems. try usign localhost for your host name instead of your domain name.

0

Actually, I use the same connection for all the queries so that rules out the incorrect login/password. Further, I've tried successfully used the query against the database directly, as well as taken other queries known to be good and tried them, but they all fail just in this block of code.

I had also tried as you suggested, but result is actually "1" afterwards, shouldn't it be "Resource ID#x"?? I'll still go back and try again, but I'm not to hopeful...

I know I'm missing something, but I just can't seem to get it.

Thanks.

0

Take a look at your apache error log, often you will get an insight there into how a query has failed. In most linux systems its under /var/logs/apache

0

Post your origional php code for the query.

Sorry, was on vacation, I'll post it tomorrow.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.