0

Hi,

I tried to restore my decompressed database 'cyberview_db_2809_2009-10-27_17h30m.Tuesday.sql'

using the command :

mysql -h localhost -u root -proot123 info < /backups/daily/cyberview_db_2809/cyberview_db_2809_2009-10-27_17h30m.Tuesday.sql

but there was no restoration.

I checked the /var/lib/mysql directory where all restored databases are located, and in the 'info' folder, the only script that was available was 'db.opt'. Nothing else was created.

Why is this? Pls help.

Tqs.

2
Contributors
4
Replies
6
Views
8 Years
Discussion Span
Last Post by peter_budo
0

I created the 'info' database using phpMyAdmin.

Today, I even tried restoring the database mentioned (which is actually the backup of the original database) using phpMyAdmin.

[ I have been using the automysqlbackup.sh.2.5 to create backups daily using the crontab.]

But the error returned was :

-- Server version 5.0.77
/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;

MySQL said:
#1065 - Query was empty

But when I create another database, and restore using the original database, I don't have such a problem. So I assume that the problem is in the database backups itself.

Is it because the backup script is not good enough or what is causing the problem with the backups? Are the database backups corrupted?

0

Hi,

I realize that the database that is being backed up daily automatically using automysqlbackup.sh.2.5 are corrupted or has error in it.

I know this because I am unable to restore the backups using neither the command line nor phpMyAdmin.

I am returned with the error : 1065 : Query is empty command when I try to restore.

Pls give me a solution to repair the corrupted backups.

Tqs.

0

I'm not sure, databases are secondary for me as I'm programmer. If you have knowledge of SQL you may try to import back database in chunks of data.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.