0

hey all, i've worked with sql server 2000 before and configured the odbc driver to connect to it, using tcp/ip, named pipes, sql admin (sa), and so on....now we're starting to get involved with mysql and are trying to configure myodbc to talk to mysql so queries and tables and whatnot can be added to the mysql db through excel.....i installed mysql on our w2k server box and i've tried setting up myodbc even on that and its not working. not familiar with how i'm supposed to configure it. we want myodbc to be setup on a client machine and connect to mysql through that....if you need any more information or are confused about anything, please let me know....thanks for the help!

oh, myodbc version 3.51.11 and mysql version 4.1.12a

3
Contributors
10
Replies
11
Views
12 Years
Discussion Span
Last Post by techniner
0

thanks for the article...i read through it and got everything setup until i reached the user name and password portion. it says to run the winmysql.exe under the bin folder but i do not have that file and cant find it anywhere. the exact version of mysql is 4.1.12a-win32 so i figure that file shouldve been extracted to that folder upon install, correct? please let me know how to obtain this file because thats the step i cant get past is the user name and password. when i setup mysql on the server, it used mysqladmin as the root user but thats not working. thanks for the help!

0

This is a windows admin utility.

THis should have installed when you instaleld mysql.

it is under the c:\mysqlroot\bin\ directory.

0

i think what happened is i downloaded the stripped down version of mysql that all it gave me was a cmd line interface with no GUI. any ideas of where i can download the full version? every site i've gone to has zip files that download and cant open because of invalid zip files, and only show as 547B....and its supposed to be around 40Mb. any help would be appreciated! thanks!

0

ok, i must be missing a step then or installing this incorrectly....i used that site to download from, the first time i downloaded it, i used the "without install" package which is y i said i downloaded the stripped version. so then i went back and downloaded the full package which was 38mgs. i extracted that fine, ran the setup file, configured it using the instance config program, set it to minimum usage because other applications are on that server, enabled tcp/ip port so others can query information from client machines, 10 users, created the root account, which should be mysqladmin by default, gave it a password.

finished the install, it started the services, a DB was created inside it, i search for the winmysql.exe file and its nowhere to be found?? myodbc was downloaded and installed as well, i go to the system dsn tab to add it, the login tab asks DSN, description, server, user, pw, and DB....i add those in on the local server and use loopback for server, and the default root admin and pw and that doesn't work....i also type the db that was created.

if you have anymore ideas of where i went wrong or how to obtain that winmysql.exe file, that would be very much appreciated....thanks!!

0

thanks for the link....i did download it and install it but i also re-ran the instance config wizard and took out the create security option all together which somehow allowed me to connect locally with no security and with root and pw from remote machine <<shrug>> but it so far seems to be connecting.

thank you guys so much for your help!! and i will post up again if i run into more issues.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.