0

PREFACE:

My name is Al and I'm a loving moron who locked himself out of MySql. Alright, Let's rock.

I don't exactly remember changing my password, but since I was in the Terminal using commands like -u password, I think I might have done it on accident.

So... I need to change it back. And I don't want a work-around because I'm loving frustrated and confused and I want I back to normal, which I must confess: Was anything but normal when it was normal.

WHY I'M A MORON:

Two weeks ago, I couldn't have told you where my bin folder was located... Now I can tell you where 5 of them are. As well as 3 mysql, 2 apache & 8 php folders. So when you say "Hey, put the file in the php and connect it to the thing" please tell me which folder, so I don't crack my head on the screen again.

Lost In translation: I understand YourPasswordHere. I'm not an idiot, I'm a moron. When you start adding quotations and parenthesis around it, I'll assume that I'm supposed to add those. I understand alot better when thing are highlighted in bold.


DETAILS:
Macintosh G5 running OS 10.4.5
My "former" MySql password is root and I want it back.
My apple username and password: albert/apple
I have 3 versions of mysql installed and they are:

mysql-standard-5.0.19-osx10.4-powerpc
mysql-standard-5.0.19-osx10.4-powerpc-64bit
mysql-standard-4.1.18-apple-darwin8.2.0-powerpc
PHP version 4
PHP version 5


TROUBLE SHOOTING:
Every single thing in the world I have tried has resulted in the same two errors:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

BEEN THERE DONE THAT:
People kept telling me to downloaded this Mamp thing and that it would somehow solve all of my php/mysql problems. Well, it did for about a week until this whole password thing went down. I first noticed there was a problem when I tried to start Mamp the other day and got the red MySql light and the green Apache light. When I tried to open the Mamp start page it says: Error: Could not connect to MySQL server!

So I tried to reset my password:
/Applications/MAMP/bin/mysql4/bin/mysqladmin -u root -p password

Grant privileges:
mysql GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost'

following the MySql instructions:
mac:~ albert$ mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('root');

And got me this:
-bash: syntax error near unexpected token `('
mac:~ albert$ love u
-bash: love: command not found

And every other command in the book.
And people keep telling me to type commands, but they're not telling me what to type when it asks me for my password. The typical forum guy comes along and is like "Hey buddy, type this in the Terminal" and when I come back to tell him it asked me for my password, he's gone with the wind.


So, in attempt to restore my username and password I decided to uninstall everything:
1) I tried to uninstall Mamp by deleting the Mamp folder.
2) I tried to uninstall all 3 accounts of MySql by deleting the folders from /usr folder and deleted the preference pane.

And with my capacity, I think that's the way to go... Only problem is, it didn't reinstall the root user.

I even checked the the "official" MySql manual. With over 5,000 pages, they should consider renaming it to the MySql Labyrinth.

2
Contributors
1
Reply
2
Views
11 Years
Discussion Span
Last Post by DMR
0

Hi Moron,

Let's do this without the profanity from here on, OK? We are a family-oriented site, after all. :mrgreen:
Please read our posting rules if you are unclear on this or any other aspect of forum usage here.

Thanks.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.