0

My website show below error.

Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET/@@@@@@.net/
Reason: Error reading from remote server
Apache/2.2.15 (CentOS) Server at hostgator.com Port 443

Response from Hostgator:

The site is currently expericing MySQL timeout due to the queries that the site is processing is exceeding the maxium time allowed. The query which is getting killed by the server is attempting to exicute "SELECT option_name, option_value FROM wp_options WHERE autoload = 'yes' " and this is most likely occurring due to the wp_options database table being in excess of 10GB.

How to change MySQL timeout / maximum time allowed? Where can change and where can i find these settings?

2
Contributors
1
Reply
13
Views
1 Year
Discussion Span
Last Post by ryantroop
1

It's likely something you will have to contact the host to help you with. Most of the time, shared VMs will have a hard cap limit on what they can execute and how many resources they can take up, based on what you pay for.

As an alternative, how about you limit your query down to something a little more realistic. If you are getting that many results with a 10gb database, what good is all that data doing you? You may consider pagification, or simply being more concise with the data you are looking for.

You may also wish to look at their TOS as it references exactly what is happening to you :-/

TL;DR - call them or fix it so you're not pulling so much data.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.