0

hi,

i have indy 10 installed on Delphi 7 personal, and am trying to load a simple text file on server using ftp

here's my code

if ftp.Connected then ftp_Kitten.Disconnect;
ftp.Host:='xxx';
ftp.Username:='xxx';
ftp.Password:='xxx';
ftp.Port := 21;
ftp.Connect;
ftp.Put('c:\ida.txt', 'ida.txt', true);
ftp.Disconnect;

and when i run my app, i am getting the following error :

Project1.exe raised exception class EIdRepluRFCError with message "APPE':command unrecognized'.Process stopped. Use step or run to continue

I am beginner in Delphi and after hours of researching the web, i truely don't know how to solve this issue.

Thanks for your help

2
Contributors
2
Replies
3
Views
9 Years
Discussion Span
Last Post by python_dev
0

I know nothing about APPE. Everything I found online refers to weaves and knits... ???

In any case, it appears to be a server error. Check that the server you are connecting to actually supports APPE. (I know Medusa doesn't.)

If you actually know what half this means, you know more than I.

0

Hi,
Actually you were right, i used a different host and it worked)

Thanks for helping me out.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.