0

Hey everyone,

we're still working trying to get Linux to communicate to our robot via an RS232 port. We added this code to the project in Mono:

Using System.Ports.IO
SerialPort ports = new SerialPort("ttyS0",19200,Parity.None, 8, StopBits.One);

We can't get anything sent out of our COM ports. We're not even sure if we're coding it correctly. Is ttyS0 (we've tried S0-Sf) what we should be putting in the code? Please help!!

thanks!

2
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by Duki
0

Start at the beginning

Does your kernel have serial built in?
If so, what serial ports does it find? and tell you are available?

0

I'm not sure. We tried some command, can't remember what it was, and it showed ttyS0-3

0

Well, having the kernel support would be somewhat essential to your program, so it would make sense that you learn how to tell.

If you are sure you have ttyS0, thats a terminal running through a serial port, not the serial port itself.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.