im using windows xp, and ive installed and unistalled dev C++ several times and i can not get it to work (compile and run) for any program even "hello world". even the dev c++ examples show a [linker error].

the code exactly is:

[Linker error] undefined reference to `__cpu_features_init'
ld returned 1 exit status

can someone please help me,
thanx

When you uninstalled it, you removed the leftover file?
You're using the current version?
Installed it to the default directory? I tested it on two XP machines, and it would only work in the default, but fine in other directories on other OSes.

If you already tried that, perhaps update the compiler to the current version(MinGW 5.*).

i have ver. 4.9.9.2 i used ccleaner to uninstall it and uninstalled everything for it. and where/how do i update minGW? in tools / update?

thanx

now i installed it under its default dir. but it still wont work. do i have to copy them to a folder in dev dir.?

Thanx Guys i figuered it our. i went to tools, update, and updated most from mingw group....runtime, win32 and looked through all the updates. downloaded a few and it worked. thanx guys.

This question has already been answered. Start a new discussion instead.