Hi! I am a total novice on programming!

Can someone tell me a solution for this problem?

1. I made a simple program.
2. I debugged it and tested it. It worked fine.
3. I compiled it and tested it again on my computer. It worked fine.
4. I copied the executable file from my computer to my sister's computer and tried testing it there. It doesn't work. It gets an error message says something like "Unable to launch application. Error 0xc8somethingsomething"

I thought it was just the program that had a problem. I tried making another program that does nothing but display a message box saying "Hi!" I compiled it. It worked on my computer, but again, it didn't work on my sister's computer. I tried it on other computers to, but they all get the same error. All except my computer.

What should I do? Do I need to copy other files as well?

I would be grateful if someone can tell me a working solution for my problem. Thanks!


P.S. All the computers that I tested my application on was Windows XP SP3 Pro edition, including mine.

You should not copy executables directly. What you need to do is create an installer for your assembly (project). You can do this by going to "File -- New Project" then select "Add to existing project". Use a Setup or Setup Wizard project. I think it is under the "Setup and Deployment" category in the new project window.

Also please inlclude a screenshot of the error.

She may not have the .NET framework installed :( The installer project will detect dependencies and let you know what the problem is.

Hi! Thanks for replying. But I have already tried making a setup project, but not with VB itself. I made my setup with a program called Install Creator Pro. Does that count? I installed it on a separate computer and it still didn't work. If I have to make a setup with VB, can you tell me in detail so that a novice programmer can understand? Thanks!

Oh yeah. About the screen shot, I would've gave you one, but my XP is in Korean. But if I translate it to English, this is what it's basically saying: Unable to initialize application(0xc0000135) Press OK to exit program.

It’s either the compiler has a problem or the program has a problem. But the program can’t have any problems because nothing’s wrong with the source code. Am I right?

Also, do you think this is happening to me because I'm using the Express Edition?

Thanks again!

And yeah. I think you are right. My sister didn't have .NET Framework installed.

Thanks guys! It works! All I had to do was simply install .NET Framework! Thanks guys!

You're welcome

Please mark this thread as solved since you have found an answer to your issue and good luck!

hi i would like to advise you to install net framework and also to try install an english based OS maybe this could help you thanks!

This question has already been answered. Start a new discussion instead.