hello everyone hope all ok

i'm facing a problem in Netbeans in that when compiling no error exist but when running nothing happen or displayed, can anyone help me in it plz

is it a console app? are you making a frame? what does your main method look like? We need more information than "its not working"

my code is too large to post it here what do u think i shall do?

Add some System.out.println calls in your methods and print some debug messages. Add some in your main method. You may also want to print any exceptions that you get.

i've tried this too but the same problem
i'm trying now to reinstall Netbeanse again & i hope it'll work

If you have a large application you shouldn't wait until its finished in order to run it.
You should be testing it many times during the development. With every change you make, run it. So if for some reason the application stops running it means that your previous change was the problem and you can undo it.

Before you reinstall try to comment all your code and then start adding bit by bit and run it in order to find the error.

Can you run a hello world app in netbeans? Have you run this application in anything other than netbeans?

I find it very hard to belive that you have made a program right untill the end without ever running it! As javaAddict said, what do you expect?

If you have run it, and know you code is right, then fair enough. Though you are still giving very little information - is there any output to console? Can you run other things? Have you run it before? If you coment out everything int he main method exept a println does that line print? You have told us you have a problem, and that the code is too big...

when i run everythin either small program or not it gave me:
run:
C:\Users\dell\.netbeans\6.9\var\cache\executor-snippets\run.xml:52: java.io.IOException: Cannot run program "C:\Program Files\Java\jdk1.6.0_22\bin\java.exe" (in directory "C:\Hanaa ‫‬\uni\third year\M257\tama\q2\q2"): CreateProcess error=267, þþÇÓã ÇáÏáíá ÛíÑ ÕÍíÍ
at org.apache.tools.ant.taskdefs.Java.fork(Java.java:798)
at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:214)
at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:135)
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397)
at org.apache.tools.ant.Project.executeTarget(Project.java:1366)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1249)
at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:281)
at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:539)
at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:154)
Caused by: java.io.IOException: Cannot run program "C:\Program Files\Java\jdk1.6.0_22\bin\java.exe" (in directory "C:\Hanaa ‫‬\uni\third year\M257\tama\q2\q2"): CreateProcess error=267, þþÇÓã ÇáÏáíá ÛíÑ ÕÍíÍ
at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
at java.lang.Runtime.exec(Runtime.java:593)
at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:827)
at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:445)
at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:459)
at org.apache.tools.ant.taskdefs.Java.fork(Java.java:791)
... 19 more
Caused by: java.io.IOException: CreateProcess error=267, þþÇÓã ÇáÏáíá ÛíÑ ÕÍíÍ
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
at java.lang.ProcessImpl.start(ProcessImpl.java:30)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
... 24 more
Java Result: -1
BUILD SUCCESSFUL (total time: 0 seconds)

Try running netbeans as administrator (right click and click "run as administrator")

Edited 6 Years Ago by hanvyj: n/a

i think the problem is with downloading eithe the JDK or Netbeans becuse when i tried the already build project same problem exist, als the file NetbeansProject that must be in my documents doesn't exist. now i'm trying to download them again hope it'll fixed.

This article has been dead for over six months. Start a new discussion instead.