i work with a guy who constantly complains and posts on stackoverflow that i am a sloppy coder (he is a web developer, i am a .net developer, he has never actually looked at my programming).
but curiously, i researched. The only thing that I do not follow with best practices is certain .net naming conventions. I have developed a habit of using _s (function_name) and intInteger, strString, blnBoolean.
he says i am wrong and it is sloppy and not efficient. I should do it stringName, functionName, intergerName, booleanName.
is it really that big of a deal? is something magically going to happen if i break my old naming convention habbits? I use option strict on, option explicit on, comment what my code does in sequence, provide strong error handling which emails me the database query (if there is one) what went wrong who it went wrong for, what application and what function they where using when it went wrong. I use alot of structure and keep things need and clean, i use configuration files and i keep my database structered in clean, hell i even use database.table.column whenever i want to select/update something so i know what i am looking at
does my naming convention make me a sloppy coder
feedback is appreciated like always.