0

Hey, im trying to get some information out of my database, which i have tableadapter and dataset. Both created with the VS2010. I have made 4 queries in the tableadapter taking different parameters, to make a WHERE clause in the sql sentence.
But it simply doesnt work and i dont know where... here is one with 1 parameter:

SELECT        Medlemmer.Fornavn, Medlemmer.Efternavn, Medlemmer.Studienummer, Medlemmer.Email, Medlemmer.Studiested, Medlemmer.IDA, Medlemmer.PROSA, 
                         Medlemmer.IndmeldelsesDato, Medlemmer.BetalingsBeløb, Medlemmer.BetalingsType, Retninger.retningNavn
FROM            Medlemmer INNER JOIN
                         Retninger ON Medlemmer.retningID = Retninger.retningID
WHERE
                       Medlemmer.Studienummer=@Studienummer

But when i preview data with it, it doesnt show any at all. And i have checked that the data is present.
Please help me
Sincererly
Anders

1
Contributor
2
Replies
3
Views
6 Years
Discussion Span
Last Post by AMetnik
0

Ok first one works good. but when i try to do one with a parameter for coloumns it doesnt work..

SELECT        Medlemmer.Fornavn, Medlemmer.Efternavn, Medlemmer.Studienummer, Medlemmer.Email, Medlemmer.Studiested, Medlemmer.IDA, Medlemmer.PROSA, 
                         Medlemmer.IndmeldelsesDato, Medlemmer.BetalingsBeløb, Medlemmer.BetalingsType, Retninger.retningNavn
FROM            Medlemmer INNER JOIN
                         Retninger ON Medlemmer.retningID = Retninger.retningID
WHERE @coloumn=@value
0

Problem seems to be the parameters in visual that aint doing their job right :-(

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.