0

Good Day All

I am accessing an FDB Database with a WCF service. locally it was working fine, but now i want to access the service that is stting on a remote location. my Connection string looks like this

<add name="FDBConnectionString" connectionString="User=SYSDBA;Password=masterkey;Database=\\192.168.03.14\Database\SCHOOL.fdb;DataSource=192.168.03.14; Port=3050;Dialect=3; Charset=NONE;Role=;Connection lifetime=15;Pooling=true; MinPoolSize=0;MaxPoolSize=50;Packet Size=8192;ServerType=0;"/>

i get an Error when i try to open the Connection

unavailable database

if it take this path and access it fire explorer

\\192.168.03.14\Database\SCHOOL.fdb

i can get to it. i have give all the possible permissions on the file and the Folder. am not sure what is the problem now.

Thanks

Edited by vuyiswamb: n/a

2
Contributors
2
Replies
5
Views
6 Years
Discussion Span
Last Post by vuyiswamb
0
Database=\\192.168.03.14\Database\SCHOOL.fdb;DataSource=192.168.03.14;

Why do you have the source listed in both the database and datasource? You need to remove it from the database. You might need to remove the '\Database' or move it to the DataSource parameter, I don't have firebird to test.

Also, next time, it would help if you told us what database you are using rather than making me search the internet :)

0

Thank you very much for your reply.

The above code is the connection string i used , the problem was that i was supposed to use it like this

Thank you very much for your reply.

The above code is the connection string i used , the problem was that i was supposed to use it like this

User=SYSDBA;Password=masterkey;Database=[B]192.168.03.14:\\Database\SCHOOL.fdb[/B] ;DataSource=192.168.03.14; Port=3050;Dialect=3; Charset=NONE;Role=;Connection lifetime=15;Pooling=true; MinPoolSize=0;MaxPoolSize=50;Packet Size=8192;ServerType=0;

so i have added an extra slash to show that it is a share folder and a Colon, this are firebird rules in the connection string

Thank you


so i have added an extra slash to show that it is a share folder.

Thank you

Edited by vuyiswamb: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.