Hi everyone, I recently had to wipe my computer and re-install everything from scratch, including Dev-C++. When I create a Win32 application project and try to compile it, I get a "[Build Error] Error1" message in the compiler log. I know that the code doesnt have any errors in whatsoever, because this even happens when i begin projects fresh and try to compile them, I still get the same error. i have tryed re-installing it numerous times...I have tryed running Dev-C++ on my dads computer, and it seems to work fine...therefore I tryed running Dev-C++ on my computer using my dads installation over our LAN and I have the same problems again. Im running the latest version of Dev-C++, with windows XP Professional with service pack 1...anyone else ever had this problem or know how to correct it ?

Have you tried compiling directly from the terminal?

gcc filename.c -o filename.exe
[i]or[/i]
g++ filename.cpp -o filename.exe

I havent tryed that, but how would I compile a project using many resource and header files aswell as source files?

Well, header files are #included in the source files (I hope), and resource files can be compiled in too, I believe:

g++ file1.cpp file2.cpp file3.res -o filename.exe

I have the same problem..... I have tried re-installing it at elast 5 times from 3 different versions of the program and still nothing new has happened, I have a couple of friends who are more experienced in the computer field, who are going to try and help me with sorting it out....but until then I'm in the same boat as you.... I have also posted something on a different site about this problem... If I come up with anything then i will get straight onto this site and explain the problem :)

This article has been dead for over six months. Start a new discussion instead.