0

Hi there.

I'm having a strange problem. I have a TTimer on my main form that should trig 500 msec. after the form is created.
It works fine when I run from IDE, but when I run it on other W7 PC's the main form is created, but the timer doesn't fire. (Some components are not updated) If I click a control, everything is updated and the timer fires and every thing is fine. If I run it on PC with Delphi installed, it works fine. No problem.

Code in MyForm.OnCreate is executed fine. Timer.Enabled := True makes no change.

Any idea what causes this? I'm really stuck here.

Best regards

Peter.

2
Contributors
2
Replies
3
Views
5 Years
Discussion Span
Last Post by PeterVrist
0

Have not seen this behaviour before. Unfortunately, I cannot try your case, as I do not have D7, nor a Win7 PC without Delphi installed. Are you sure that you do not have code somewhere that disables it by accident (can you show some maybe)?

1

Error found! It was setting a TMS PlannerDatePicker to todays date that caused my app. not to look at the timers. Done it many time, but in this application something goes wrong. Changed it to the standard Delphi component and it works now.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.