Ok, so my form displays an error saying "run time error. could not find installable ISAM." everytime i run it.
And its pointing at "conn.Open" part of the code when i run it.
heres my code:

Dim conn As ADODB.Connection
Dim rec As ADODB.Recordset
Dim rec1 As ADODB.Recordset
Dim rec2 As ADODB.Recordset
Dim rec3 As ADODB.Recordset
Dim esql As String
Dim esql2 As String
Dim esql3 As String
Dim esql4 As String
Dim searchvar As String

Private Sub Form_Load()
Set conn = New ADODB.Connection
Set rec = New ADODB.Recordset
Set rec1 = New ADODB.Recordset
Set rec2 = New ADODB.Recordset
Set rec3 = New ADODB.Recordset
conn.ConnectionString = "Provider=Microsoft.Jet.OlEDB.4.0;Data Source=" & App.Path & _
                        "F:\my computer project\ParlourDesign.mdb;Persist Security Infor=False"
**conn.Open**
esq1 = "select * PartPayment"
esql2 = "select * from Receipt"
esql3 = "select * from ReceiptService"
esq14 = "select * from Service"
rec.Open (esq1), conn, adOpenDynamic, adLockOptimistic
rec1.Open (esql2), conn, adOpenDynamic, adLockOptimistic
rec2.Open (esql3), conn, adOpenDynamic, adLockOptimistic
rec3.Open (esql4), conn, adOpenDynamic, adLockOptimistic
rec.MoveLast
rec.MoveFirst


Dim RR As Integer

FlexService.Clear
FlexService.Rows = rec.RecordCount + 1
FlexService.Cols = rec.Fields.count
FlexService.FixedCols = 0
FlexService.TextMatrix(0, 0) = "Service"
FlexService.TextMatrix(0, 1) = "Quantity"
FlexService.TextMatrix(0, 2) = "Price"
FlexService.TextMatrix(0, 3) = "Total"
rec.MoveFirst
RR = 1

Do While Not rec.EOF()
FlexService.TextMatrix(RR, 0) = rec.Fields("Service")
FlexService.TextMatrix(RR, 1) = rec.Fields("Quantity")
FlexService.TextMatrix(RR, 2) = rec.Fields("Price")
FlexService.TextMatrix(RR, 3) = rec.Fields("Total")

RR = RR + 1
rec.MoveNext

Loop

End Sub

And this is how my form looks like:
http://i213.photobucket.com/albums/cc228/rose_408/screen_zps1383ab65.png

Please please help! I'm having serious troubles connecting VB to M.Access. AND I'VE TRIED EVERYTHING!
PLEAAAAASE HELP ME OUT!

Edited 3 Years Ago by Ayesha.Shahnawaz

This error can happen when you have a parameter in your connection string that is not valid for the given provider. Try changing

Persist Security Infor=False

to

Persist Security Info=False

and see what happens. What type of database are you trying to open?

I could be wrong, but is'nt "Persist Security Info" a parameter for connecting to SQL Server and not an old Access mdb file?

conn.ConnectionString = "Provider=Microsoft.Jet.OlEDB.4.0;Data Source=" & App.Path & "F:\my computer project\ParlourDesign.mdb;Persist Security Infor=False"

This is your problem right here. You are telling the connection to go to your app whilst you refer to an F drive as well. If your app is on f drive, its trying to open to f:/my computer project\ParlourDesign.mdb/f:/my computer project\ParlourDesign.mdb

If your app is in "f:my computer project" use app.path & "\my computer project\ParlourDesign.mdb"

Edited 3 Years Ago by AndreRet

I could be wrong, but is'nt "Persist Security Info" a parameter for connecting to SQL Server and not an old Access mdb file?

That's why I asked what type of database was being accessed. If the parameter is not valid for that type of database then you can get the error.

The OP is using MS Access -

Microsoft.Jet.OlEDB.4.0

and the database is a .mdb

My 2 1/2 cents worth :)

Thank you all for your help! I made a really stupid mistake by typing in 'infor' instead of 'info' so thank you Reverend Jim for pointing that out! And AndreRet, I did exactly as u said and yup, it worked! Thank yooou! ^_^
However, a new error now pops up when i try to run it. This time its about:

 FlexService.TextMatrix(0, 0) = "Service"

It says "Subscript out of range".
God, my code is all messed up and I dont even know what I'm doing. I'm in need of some serious help cuz my teacher is absolutely terrible at teaching! :|
Any further help would be appreciated! :)

P.s Yes, I'm trying to access MS Access! c:

Edited 3 Years Ago by Ayesha.Shahnawaz: another porblem rises

:) Only a pleasure.. This question was answered. Please open a new thread with your flexgrid error...

Out of range means it is calling coloumns that does not exists. We will answer THIS problem on the new post. :)

Please mark as solved, thanx.

:) All well. Still not marked as solved yet...

Please do so by clicking on the bottom left "Mark This Question As Solved" thanx. See you in the new post...

Edited 3 Years Ago by AndreRet

This question has already been answered. Start a new discussion instead.