-2

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

The OS is Windows 7 and its of 32-bit OS type

After publishing I get the above error. This OS is Windows Server 2008 R2 and is of 64-bit..

I have changed the Platform from Any CPU to x86... the error still remains

I tried to change the target Platform to x64 and also to x86...
Application Pool's default setting for Enable 32-Bit Applications was False and I set it to true as .. Nothing worked!

Can anybody tell me if I have to change the Platform field or Target Platform field? and what should I change it as?

Edited by hookedtocsharp: Added App Pool's details

Votes + Comments
Lied about attempted resolution steps as the OP proves by their own "solution" further in the thread.
4
Contributors
6
Replies
24
Views
4 Years
Discussion Span
Last Post by hookedtocsharp
0

Did you check the Event Viewer for any errors in IIS? Also verify that the Application Pool used for the website (which I assumed it is) is correctlly set and started. Verify the .Net Framework for the App Pool. Did you run aspnet_regiis ?

0

Does the 500 page give you an exception stack? If it does, pasting that will help determine the cause. Unfortunately the error code 500 just means something went wrong. It's a very generic error code :(

Edited by Ketsuekiame

0

@Pitic and @Ketsuekiame I found out a simple solution (for which I slogged for 2 days).

In the Application Pool -> Default Web site -> Enabled the 32-Bit Application Pool and set it to true.. (Default value is false).

This resolved the 32bit and 64bit compatibility issues and 500 Internal server error problem !

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.