My top-level package is "com.gmail.email.aviersproject". In .aviersproject have a class that holds my main method and a package "summonerdata". In that package I want a class that gets summoner data by screen scraping.
My question is what a good name would be?
I was thinking SummonerDataScreenScraper or SummonerDataScraper but it feels kind of long
(the import statement would be: import com.gmail.email.aviersproject.summonerdata.SummonerDataScreenScraper"..) and someone said I'd be continueing the tradition of bad class names and linked http://projects.haykranen.nl/java/
Since the package is summonerdata should I shorten the class name to "Scraper"? "ScreenScraper"?