When I add a particular form to my project (AdminConfirmForm.cs) I can no longer access design view of Form1.

It appears to run a particular section of the code from a static class (Init()), but since the part of the code it runs should only occur if the folder it is run from requires admin rights, it makes even less sense, since it's just the debug folder in my project in my documents folder,

Before the AdminConfirmForm was added (which is not invoked in my project incidentally) I tested the app in many locations and the message box that appears only shows when I run app from C:\ or program files etcetera, never from a non secure location,

There is more info on my problem here, starting from 4th reply, I should probably have started a new thread straight away, sorry.
https://www.daniweb.com/software-development/csharp/threads/494491/administrator-icon-on-messagebox-button

here is a video which shown the problem.

https://www.youtube.com/watch?v=wsoKzroiPCI

I have tried many things including creating a new project and pasting the code into it.

Hoping someone has an Idea as to what I might try next.

Well I've began to get closer to the problem.
One line of code where I'm setting the title of the form from a user setting.
Made another video, hope you don't mind :)

https://www.youtube.com/watch?v=JOQKBKm3WIs

Still don't understand why VS freaks out and runs part of my code though, instead of throwing an error if what I'm doing is illegal.

It's all very weird.

Edited 1 Year Ago by Suzie999

  1. Do not ever show your app's source to public; especially when its written for customer; its simply not fair; if you want to share sth, just make (and share) code snippet. (use vb builtin function to create one),

  2. Whats your point? Whats not working for you? Add exception handling and paste debugging info.

From the second vid, my guess that there is sth wrong in your restarting instruction.... whatever form it has (class, OLD, modified) just wrap it with exception and paste debug info.

Edited 1 Year Ago by Wojciech_1

I thought my point was pretty clear.

VS is acting all weird, and running my code when I just want to view the designer.

The code runs and works perfectly fine, with or without the indicated line commented out.

If it's some sort of exception then why is one not thrown?

Have you made sure that all the recent Windows/.NET updates are installed on your PC? Sometimes you have to go and do a manual Windows update (even if the automatic ones have already run).

Of course it could be the reverse: you need to isolate an update that's been installed which might be causing the problem. :P

If you have all the most recent updates, try Googling the symptoms/errors, to see if there's any patches or updates that need to be uninstalled.

Tekkno

Thanks, I spent many hours doing that before I posted here.

I gave up in the end, and just started from scratch and not setting the title text in that manner.

I'll have to check my updates, might have been installed while someone else was using the computer.

Thanks, I spent many hours doing that before I posted here. I gave up in the end,

LOL! Understood!
Even if it looks like the updates are current I'd try running any that are listed, manually, anyway; ya never know. I'll take alook at your symptoms and see if I can find anything further (you know what they say about two pairs of eyes... :) )

By the way: do you get these kind of errors on any application you run, in VS2010, or just this one?

Tekkno---

Edited 1 Year Ago by TekknoDraykko

This article has been dead for over six months. Start a new discussion instead.