Hi! im a student needing help for my thesis project. im currently working on a supply chain management system.

i have created a sales form wherein you can input the customer order. adding the customer and product information and subtracting ordered product quantity works. im having problems with my report generation. im using odbc for connection and ms acccess. i created a data environment and connected it to my database. made something(sorry, im not good at programming) with sql builder.

after getting everything done with data environment, i dragged and dropped the fields to my data report, arranged everything and ran it. when i click the print cmdbutton to show the report, the report shows but there is nothing in it. so please please someone out there! please help! thanks! :D

You have a loosly worded problem. Hire a tutor for 2 hours and you'll have the answer quickly. It sounds like you do not getting a match between the tables you're trying to read. But if you don't understand SQL at all then you're in trouble from the start. The mentor on site is really what you need.

Are you sure the table contains any data ?

yup. i've checked out the database.... the data report is showing but it displays no items. oh btw, thnks! :D

You have a loosly worded problem. Hire a tutor for 2 hours and you'll have the answer quickly. It sounds like you do not getting a match between the tables you're trying to read. But if you don't understand SQL at all then you're in trouble from the start. The mentor on site is really what you need.

uh... what did u mean by me having a loosly worded problem? thanks mikepf!

how about the data source and the data member have you already done with it? you must select the data source and the data member then right-click in your data report then select retrieved data then use your drag and drop hehehe hope it would help to you

Hi.
Well, follow these steps:
As a tester,
from your data environment, create a new command (and name it cmTester) then set the properties.
The data properties table will appear. Select the tables from the database you wish to use (ie drag and drop) then save the changes you are making.
Then, add a new report and name it rptTest. Align the windows as vertically and close all the other windows you dont wish to use(ie the forms you dont wish to use as of that moment)
Then drag and drop the cmTester to the rptTest and align as you wish.

Then set the rptTest properties as follows:
- data source as the data environment (from a generated drop down combo)
- data member as cmTest
- save changes..

Then from the form you wish the report to be shown ie as per your case you are using a command button, go to the code option of that command button (ie cmdPrint) and write a one-line code to show the report you are generating. (in this case our report name is rptTest therefore the code you will write under the function cmdPrint.Click will be, rptTest.show

From that compile and the report will load data from the database ie also if the database has data....

Communicate if you still have a problem and i will attach a sample project for that contains all that.

hi! i already checked the datassource and datamember. but still there's nothing when u run it. i added a label just to check if something come out. well, no problem with that. but to the items that i dragged and dropped, they display nothing when run.

still having a hard time with the reports. is there a possibility that the problem is in the table's relationship in the databes?

oh by the way, in this report i am using a query. sorry if i'm not making sense with the clues, i dont know where to start explaining so feel free to ask. hehe thanks jireh and lavendor!

Are you sure the table contains any data ?

hi. yup im sure it contains data. :D

the deadline is near and i cant seem to find whats wrong. o well. T.T

appears that i cannot upload the pdf file to your account.
But i may help you if you re-phrase the question for me.

cheers.

This article has been dead for over six months. Start a new discussion instead.