Could someone please give me step by step instructions on how to make gtkmm work with Dev C++ on windows. I've tried following the instructions on the website, but I cant get it to work. Could you please tell me exactly what to download and where to install it.
Thanks.

I installed Dev c++, GTK+ 2.x, the Gtk+/Win32 Development Environment, and gtkmm, but when I try to run pkg-config --cflags gtkmm-2.4 it says package gtkmm-2.4 was not found in the pkg-config search path. Perhaps you should add the directory containing 'gtkmm-2.4.pc' to the PKG_CONFIG_PATH enviroment variable
No package 'gtkmm-2.4' found

Try rebooting to update your path (I don't have access to a windows machine currently). If that doesn't work you could manually locate all of the necessary files.

Thanks Sturm, but rebooting didn't work, and I don't know which files I need so I can't find them myself.

Encase it helps I'm using windows XP and I installed everything with the default settings.

-Id:/dev-c++/include/gtkmm-2.4
	    -Id:/dev-c++/lib/gtkmm-2.4/include
	    -Id:/dev-c++/include/gtk-2.0
	    -Id:/dev-c++/lib/sigc++-2.0/include
	    -Id:/dev-c++/include/sigc++-2.0
	    -Id:/dev-c++/include/glib-2.0
	    -Id:/dev-c++/lib/glib-2.0/include
	    -Id:/dev-c++/lib/gtk-2.0/include
	    -Id:/dev-c++/include/pango-1.0 -Id:/dev-c++/include/atk-1.0
	    -Ld:/dev-c++/lib

Well presumably the necessary files would be in the above directories.

Thanks sturm, but I still can't get it to work. i think I'm going to try a different gui toolkit.

-Id:/dev-c++/include/gtkmm-2.4
	    -Id:/dev-c++/lib/gtkmm-2.4/include
	    -Id:/dev-c++/include/gtk-2.0
	    -Id:/dev-c++/lib/sigc++-2.0/include
	    -Id:/dev-c++/include/sigc++-2.0
	    -Id:/dev-c++/include/glib-2.0
	    -Id:/dev-c++/lib/glib-2.0/include
	    -Id:/dev-c++/lib/gtk-2.0/include
	    -Id:/dev-c++/include/pango-1.0 -Id:/dev-c++/include/atk-1.0
	    -Ld:/dev-c++/lib

Well presumably the necessary files would be in the above directories.

This article has been dead for over six months. Start a new discussion instead.