I am trying to install script.
But getting error.Error is below and can be seen here

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

If put the php.in with below text.But its not working.

register_globals = On

I added .htaccess file with below code.

RewriteEngine On
RewriteCond %{HTTP_HOST} ^cravingcatering\.com [nc]
RewriteRule (.*) http://www.cravingcatering.com/osc/$1 [R=301,L]

Please be advice.How i can fix this.Thanks a lot

Edited 3 Years Ago by mike_2000_17: Fixed formatting

Hi there,
are you running the server yourself? I mean if you're on a normal commercial hosting you're not allowed to modify php.ini. You cannot create your own php.ini - only one php.ini is The One.

If you are running your own server then maybe you have modified wrong php.ini. Sometimes there are various copies of php.ini laying around the box due to for example, having both PHP4 and PHP5 installed. To verify that you got the right php.ini run phpinfo().

Or the script you're trying to install has a bug and thinks register_globals is disabled while it is not. What script is it?

The directive you used for turning register_globals on is correct so it must be something else. .htaccess has nothing to do with it.

The server probably needs to be restarted.

Scripts that rely on register_globals=On are rather outdated and are possibly a security risk (what is it?)


Matti Ressler
Suomedia

This article has been dead for over six months. Start a new discussion instead.