I installed Osc store. I was having problem with Register_globle.which was not solved.I find the link i use this i successfully install store.But still unable to login to admin panel.

On index page still have this error.I appied different permissions 444, 644,755 but unable to remove the Message

Warning: I am able to write to the configuration file: /home2/cravingc/public_html/store/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

At Admin panel,
I am still haveing the message

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

Please be advice.
Thanks

Fore register global:
If you have access to php.ini file, you can change
register_globals = 0
to
register_globals = 1

or in a .htaccess file put
php_flag register_globals 1

Instead of numbers you can use On and Off as well, 0->Off and 1->On

For file permission, you can set configure.php file permission to 0644, I guess that would help.

Fore register global:
If you have access to php.ini file, you can change
register_globals = 0
to
register_globals = 1

or in a .htaccess file put
php_flag register_globals 1

Instead of numbers you can use On and Off as well, 0->Off and 1->On

For file permission, you can set configure.php file permission to 0644, I guess that would help.

Thanks for your help and for everyone who help me in advance.

File permission works and problem solved.

But i changes the php.in file ON to 1

and i am receving this error now.Please be advice.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@cravingcatering.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

If register_global was already set to On in php.ini file, I would suggest you to leave it like that, it should be fine. If setting it to 1 gives you the error, try On again and if it still gives you an error, just let me know. it sounds interesting.hmm!!!

If register_global was already set to On in php.ini file, I would suggest you to leave it like that, it should be fine. If setting it to 1 gives you the error, try On again and if it still gives you an error, just let me know. it sounds interesting.hmm!!!

register_global is now set on On in php.in file and working fine on front end.But at admin panel.I am unable to access.I am receving
Internal Server Error

Please be advice.
Thanks

Dunno where you obtained your osC - the latest version runs with register_globals=Off

I would suggest that you upgrade before going further, or even better, wait a few weeks for our own cart (GPL) to be released... its miles more advanced than osCommerce.


Matti Ressler
Suomedia

I'm not %100 sure if that would help but try to set global_register Off in php.ini then try your script to be sure it doesn't give any error and then set register_global on with .htaccess file as I've gave the example above.

This article has been dead for over six months. Start a new discussion instead.