0

Hi y'all,

I've run into problems while running my program in eclipse. Its a Jruby application that uses Glimmer to create GUI components. I've followed the instructions as in www.indijava.in/community/article/Glimmer-Using-Ruby-to-Build-SWT-User-Interfaces within eclipse, yet I can't seem to get it work. Am trying to run a simple example as the one below:

#require "java"
require "C:/org.eclipse.glimmer.core/src/swt.rb"

class HelloWorld
  include_package 'org.eclipse.swt'
  include_package 'org.eclipse.swt.layout'
  
  include Glimmer

  def launch
    @shell = shell {
      text "SWT"
      composite {
        label { 
          text "Hello World!" 
        }
      }
    }
    @shell.open
  end
end

HelloWorld.new.launch

Yet, I keep gettint the error below:

C:/Program Files/jruby-1.1.5/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:38:in `require': no such file to load -- facets (LoadError)
	from C:/org.eclipse.glimmer.core/src/glimmer.rb:17
	from C:/org.eclipse.glimmer.core/src/glimmer.rb:16:in `require'
	from C:/org.eclipse.glimmer.core/src/swt.rb:16
	from C:/org.eclipse.glimmer.core/src/swt.rb:5:in `require'
	from hello_world.rb:5

Any suggestions??? :-(

2
Contributors
1
Reply
2
Views
8 Years
Discussion Span
Last Post by reflexer
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.