0

i want to execute the mail function but it does not work......
The below error has occured......what can i do/i don't know how to get the php.ini file..............................
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\karthi\cookiesandsessions\mailact.php on line 7

2
Contributors
1
Reply
2
Views
8 Years
Discussion Span
Last Post by cwarn23
0

I had the same problem with xampp and means that your mail server is not turned on or not configured. It's a nightmare getting it running as I have tried and failed. But it is possible to set the php.ini to not make to mail() function just not do anything at all - in other words, if you configure the php.ini file right then no emails will be sent and there will be no error message even with all error messages enabled. But I assume that you want the mail() function to work so if this is purely for localhost then I would suggest try looking into alternative pear libraries etc. Or if your very lucky you might be able to even get the mail server running on your computer which comes with xampp. Hope that breif explination helps.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.