0

I am trying to setup a tomcat server in eclipse galileo java ee to test a servlet. I have web tools installed also. I created a server but when I go to my web browser and go to http://localhost:8080 I get an http status 404 error.

My server is started in eclipse. When I open the server overview page it won't let me change any of the options in the Server Locations section.

Does anyone know what is going on here? Is there something else I have to do to get tomcat working?

2
Contributors
2
Replies
3
Views
7 Years
Discussion Span
Last Post by Capra
0

Hi,
I am also trying to setup a tomcat server in eclipse galileo java ee to test a simple JSP page. I have similar problem, but no solution to it.
It gives me same error. So, if i want to see http://localhost:8080/Project/WEB-INF/Hello.jsp, it gives me error page

HTTP Status 404 - /Project/WEB-INF/Hello.jsp

.
I have tried to change server location (default server location was "use workspace metadata") , so if I put option "use Tomcat installation", it gives me Tomcat default page on http://localhost:8080 ,
but for Hello. jsp it gives me same error. Last option "use custom location" isn't even available.
Can you please help me if you have succedeed to resolve it?
I have tried other related problems, but they were solved in other version of Eclipse where this problem is solved by uncheking box
"Run modules directly from the workspace". I don't see this option here, so I am stuck. :(

Thanks.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.