0

hi, fellow programmers

im currently using phpdev and windows xp as a platform. i've been developing this website and now im trying to test it in local network. i have already installed the apache and already set the index.php in the folder www. now my problem is i keep on getting this message from my browser that says

" Forbidden
You don't have permission to access / on this server."

also know as 403 forbidden.

can anyone help me please. thanks.

3
Contributors
14
Replies
15
Views
7 Years
Discussion Span
Last Post by phpbeginners
Featured Replies
  • [QUOTE=ampLife;1077637]i already have php installed cause i downloaded a bundled installer from FIREPAGES..i already have my project running from my pc but from other local PC i cant seem to find Localhost. what do i have to do for my project to be access from my local network?[/QUOTE] Use your … Read More

0

You need to have a PHP addition installed with the apache server. PHP needs to have the interpriter for the PHP. Without it you will get the 403 error. Also apache needs to be configured to see index.php as a valid index file. Go to the PHP home page (php.net) and download the windows binaries, then go to the apache website to change your config to allow php. go to this site:http://wiki.apache.org/httpd/PHP


hi, fellow programmers

im currently using phpdev and windows xp as a platform. i've been developing this website and now im trying to test it in local network. i have already installed the apache and already set the index.php in the folder www. now my problem is i keep on getting this message from my browser that says

" Forbidden
You don't have permission to access / on this server."

also know as 403 forbidden.

can anyone help me please. thanks.

0

i already have php installed cause i downloaded a bundled installer from FIREPAGES..i already have my project running from my pc but from other local PC i cant seem to find Localhost. what do i have to do for my project to be access from my local network?

You need to have a PHP addition installed with the apache server. PHP needs to have the interpriter for the PHP. Without it you will get the 403 error. Also apache needs to be configured to see index.php as a valid index file. Go to the PHP home page (php.net) and download the windows binaries, then go to the apache website to change your config to allow php. go to this site:http://wiki.apache.org/httpd/PHP

1

i already have php installed cause i downloaded a bundled installer from FIREPAGES..i already have my project running from my pc but from other local PC i cant seem to find Localhost. what do i have to do for my project to be access from my local network?

Use your local machine IP i.e. if your machine xxx.xxx.xxx.002 then use that in another machine on your network in IE or Firefox. Then the system should see it. The other part is to check your firewall set on the machine with the apache server, sometimes your windows xp firewall can shut off the port that the service is called, port 80. Since there is a place to also verify this on your system, use the ip of 127.0.0.1. This will force the system to check itself for the port 80 opening. If there is a firewall issue, you can see it that way. The other part is that if you access the server from outside your network, the routers need to point to your apache server, and you also need to know your WAN IP. Using your WAN IP and the routers to create the pointers will allow access to all of the pages.

On another side of things did you change the pointers in apache to look for the index.php first?

0

hi there! thank u zinngu for replying to my thread. i already turned off the firewall of my local machine and i did the same for the others computers in the network but still havve no luck on the error. now for your question about the pointer. are you talking about the conf? if yes..i still dont have it change it. i still have it in default settings.

Use your local machine IP i.e. if your machine xxx.xxx.xxx.002 then use that in another machine on your network in IE or Firefox. Then the system should see it. The other part is to check your firewall set on the machine with the apache server, sometimes your windows xp firewall can shut off the port that the service is called, port 80. Since there is a place to also verify this on your system, use the ip of 127.0.0.1. This will force the system to check itself for the port 80 opening. If there is a firewall issue, you can see it that way. The other part is that if you access the server from outside your network, the routers need to point to your apache server, and you also need to know your WAN IP. Using your WAN IP and the routers to create the pointers will allow access to all of the pages.

On another side of things did you change the pointers in apache to look for the index.php first?

0

Your router needs to point the port 80 calls to the Static IP of the apache server. Did you try to call your page via IP on your system?

0

how do i point the port 80? i already called the ip using the machines ip

0

your router has two functions to do this. the first is throught the DMZ option that is on 99% of all routers. To use this click on the DMZ option and input the static ip of your apache server.

the other option is to use the port forwarding option. This is done by telling the router to forward a port to a specific machine. also included on 99% of all home use routers.

Follow the prompts in your router gui to set either of them up.

0

i found the conf and ive seen that it is set to default to port 80. i dont know what else is the problem. anyways thank for replying:) i still cant get it working

0

hi, fellow programmers

im currently using phpdev and windows xp as a platform. i've been developing this website and now im trying to test it in local network. i have already installed the apache and already set the index.php in the folder www. now my problem is i keep on getting this message from my browser that says

" Forbidden
You don't have permission to access / on this server."

also know as 403 forbidden.

can anyone help me please. thanks.

you have to edit your conf.ini in apache.

add this at the bottom of your conf.ini file in apache.

# For PHP 4 do something like this:
LoadModule php4_module "c:/php/php4apache2.dll"
# Don't forget to copy the php4apache2.dll file from the sapi directory!
AddType application/x-httpd-php .php

# For PHP 5 do something like this:
LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"

make sure you have the correct directory of your php.ini
and the name of php5apache2.dll others have different format.
php4apache_2.dll look for you php5apache....dll.

depends on your PHP Version. 4 or 5? I gave you two options.

Edited by phpbeginners: n/a

0

you have to edit your conf.ini in apache.

add this at the bottom of your conf.ini file in apache.

# For PHP 4 do something like this:
LoadModule php4_module "c:/php/php4apache2.dll"
# Don't forget to copy the php4apache2.dll file from the sapi directory!
AddType application/x-httpd-php .php

# For PHP 5 do something like this:
LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"

make sure you have the correct directory of your php.ini
and the name of php5apache2.dll others have different format.
php4apache_2.dll look for you php5apache....dll.

depends on your PHP Version. 4 or 5? I gave you two options.

hi ive check the conf file and it was just like what youve type.. im using php 4..

0

hi ive check the conf file and it was just like what youve type.. im using php 4..

check your conf.ini

if you have this.
DirectoryIndex index.php index.htm

0

hey guys i finally got it working thanks to you two zinnqu and phpbeginner :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.