when i open my website it shows www.mywebsite.com/index.html but i want to open like www.mywebsite.com do not want index.html with the url. please give me the solution how to do it.

Uhmmm, Thats wierd in my case it always pick it up automatically anyway, if you pay an external hosting you should contact their support, in the other hand if you are managing your own server then you have to find something to make a default content, for example in IIS its called Enable Default Content Page.

try it by writing entire code of index.html into default.aspx

You need to set index.htm as the default document in IIS.

Check this link.

Setting Up Default Documents (IIS 6.0).

If you are using a web hosting company to deploy you site over internet, you can ask them to set index.html as default document for your site.

thanx for the suggestion