0

hi..

i was working with php 4.2.3 and now i changed php to 5.3.1

now problem is that when i login as a user in my script i got this warning..

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively in Unknown on line 0

just for information .. i done coding for session register and register all variables in session..when user login into his/her account.

one strange thing i note that after login i can get all session variables there...

so can any one tell me how can i clear this error message ??

3
Contributors
4
Replies
6
Views
7 Years
Discussion Span
Last Post by network18
0

hi..

i was working with php 4.2.3 and now i changed php to 5.3.1

now problem is that when i login as a user in my script i got this warning..

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively in Unknown on line 0

just for information .. i done coding for session register and register all variables in session..when user login into his/her account.

one strange thing i note that after login i can get all session variables there...

so can any one tell me how can i clear this error message ??

As the warning says - it was the feature with PHP 4.2 and less and as u updated to the higher version, it will throw this warning.
In order to disable this warning , you should only set the "session.bug_compat_42 " and session.bug_compat_warn to zero -

session.bug_compat_42 = 0
session.bug_compat_warn = 0
0

As the warning says - it was the feature with PHP 4.2 and less and as u updated to the higher version, it will throw this warning.
In order to disable this warning , you should only set the "session.bug_compat_42 " and session.bug_compat_warn to zero -

session.bug_compat_42 = 0
session.bug_compat_warn = 0

where i can set it to zero ??

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.