0

Hello friends, I have one stupid problem with overlapping div and object tag.
I have slideshow (.swf) and now I want to add a div tag on the top of the slideshow, but when I try to do this then the div tag is hidden by object tag (slideshow).

How can I to do this ?

Thanks SkyDriver.

2
Contributors
2
Replies
4
Views
7 Years
Discussion Span
Last Post by Krstevski
0

Use the zindex="value" in div to get the object to the top and also use wmode="transparent" in the object tag parameter.

Edited by rajarajan07: n/a

0

Thanks man, it works.

Here is my code:

<div id="slideshow">
<!-- ##################### -->
<div style="position: absolute;">
bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla <br />
</div>
<!-- ####################### -->
        	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="930" height="350" id="slide.swf" align="middle">
	<param name="allowScriptAccess" value="sameDomain">
	<param name="movie" value="assets/templates/yale/slideshow/slide.swf">
	<param name="quality" value="high">
        <!-- ######### --> <param name="wmode" value="transparent"> <!-- ######### -->
	<param name="bgcolor" value="#000000">
	<embed src="assets/templates/yale/slideshow/slide.swf" quality="high" bgcolor="#000000" width="930" height="350" name="slide.swf" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" <!-- ######### --> wmode="opaque"<!-- ######### --> pluginspage="http://www.macromedia.com/go/getflashplayer">
</object>
        </div>

CSS of the slideshow div:

#slideshow {
	width: 930px;
	height: 350px;
	z-index: -1;
}

Edited by Krstevski: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.