0
5
Contributors
13
Replies
15
Views
6 Years
Discussion Span
Last Post by Nyight
Featured Replies
  • To clarify on a few things, if it was a mysql_connect or just a general mysql_error, php would display the problem and then continue parsing the page until it ran into a critical error. I've ran into situations where the page merely returns blank without any explanation whatsoever and after … Read More

0

If it doesn't 404 then the propagation is most likely done. Check to make sure you're index.php is working properly, e.g. edit the page from server side to confirm what is on the server side is what you want.

Another thing to check, if you're on a windows server, is that it's not trying to load or prioritize default.asp instead of index.php. I ran into this problem a while back and it kept me confused for several days.

0

Edited by Ezzaral: Removed url. Keep examples generic unless absolutely necessary to your question.

0

I clicked on the link to your site and it just shows a blank page, no HTML tags or anything. I'm assuming that there is an error when connecting to your database, usually when the "DIE" function is called. check you database name and password and username. usually "HOST" will remain localhost unless changed or if you're accessing it from a remote location.

like Nyight said, check you index.php, case sensitivity may also be an issue, ie. Index.php or INDEX.php

check the permissions, if you are using themes than check the permissions in that folder as well, make sure it's "0777" if it's unix or linux you can use the CHMOD method.

0

I'm using linux hosting. All the necessary file are available in the "www" folder.Including the index.php file..... you can check this link www.theitforums.com. It doesn't say anything. Pls help me... In the domain name control panel, already there were 2 name server address by default, i just overwrote those 2 addresses with the 2 addresses that has been given by my Hosing package provider. Thats rite na ? SInce I've never tried hosting, this is my first time. Pls help me to laund my site successfully.

If you register domains through you web host then it should automatically link to your account. if your Domain is not pointing to your "www" folder then it should automatically be a "park domain", in that case it should display a random advert or picture saying it's a parked domain or give related searches to your site, this depends on your web host tho.

I'm sure your web host should have a number or an email you can contact them by if you run into trouble like this.

0

I clicked on the link to your site and it just shows a blank page, no HTML tags or anything. I'm assuming that there is an error when connecting to your database, usually when the "DIE" function is called. check you database name and password and username. usually "HOST" will remain localhost unless changed or if you're accessing it from a remote location.

like Nyight said, check you index.php, case sensitivity may also be an issue, ie. Index.php or INDEX.php

check the permissions, if you are using themes than check the permissions in that folder as well, make sure it's "0777" if it's unix or linux you can use the CHMOD method.

As you told, in my db configuration file the "$dbhost = 'localhost' ;" dbhost name is mentioned as localhost ? where can i get my hostname ? what should be given there ? the following is the config file... what are the changes to be made?

<?php

$dbms            = 'mysqli'      ;
$dbhost          = 'localhost' ;
$dbport          = ''            ;
$dbname          = 'theitfor_ron'   ;
$dbuser          = 'theitfor_ron' ;
$dbpasswd        = '<hidden by me for safety>' ;
$table_prefix    = 'ron_'      ;
$acm_type        = 'file'        ;
$load_extensions = ''            ;
0

But in "phpmyadmin" the host name is provided as localhost only. So, i thin there is no need to change that. Pls help me to find out the problem and launch my site successfully. pls (urgent)

0

localhost should be correct, usually its the username or dbname. double check that in phpmyadmin. try creating another user for your database to see if you can connect as him. sometimes when creating new databases, webhost prefixes them with your control panel username.

Edited by qazplm114477: n/a

0

This does sound like a database problem, the classic mysql_connect function is often used in conjunction with "or die(mysql_error())", which would explain why you don't see anything in your browser.

To check everything else is working properly...

Rename your index.php file and upload a simple html file called "index.htm" containing the following code:

<html>
<head>
<title>test home page</title>
</head>
<body>
<h1>Hellow world!</h1>
<p>If your browser displays this text when viewing yoursite.com then you may be having a database issue.</p>
</body>
</html>

If you see "Hello world" in your browser when connected to your site, then your problem is with PHP/MySQL. Follow the qazplm114477's instructions for debugging mysql, or post again if you're unsure about anything :)

Edited by _Rade: added title

0

I installed phpBB through Fantastico.... I didn't show any page when i pointed to my URL. But all the other scripts installed using fantastico (ex., wordpress, joomala, etc., etc.,) are working fine. Only phpBB is displaying blank page. But I need phpBB only. So pls help me to rectify this.

0

Now I uninstalled phpBB which I installed through fantastico, and I've done manual installation by copying the files and db for phpBB3.... Configured dbhost,dbname,username and password perfectly. But now gettin 500 error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@theitforums.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Pls help me... Its irritating for last few days. Tired of trying many ways.

0

If the page is still blank, it's probably something in the header of PHPBB. I have never used PHPBB so I'm not familiar with the architecture. Check to see if PHP.ini has the display_errors is turned on. There should be a config file in PHPBB that should allows you to enter debugging mode, try checking that.

If it's an internal error then you should contact your host.

0

I installed phpBB through Fantastico.... I didn't show any page when i pointed to my URL. But all the other scripts installed using fantastico (ex., wordpress, joomala, etc., etc.,) are working fine. Only phpBB is displaying blank page. But I need phpBB only. So pls help me to rectify this.

there is an internal server error in your site which may be due to a php error
try enabling php error reporting in php.ini so that you may diagnose the problem if it is a php error

1

To clarify on a few things, if it was a mysql_connect or just a general mysql_error, php would display the problem and then continue parsing the page until it ran into a critical error.

I've ran into situations where the page merely returns blank without any explanation whatsoever and after several days of trying to figure out what was going on, I decided to echo display_errors. My host, by default, had it disabled.

Anyway, to check to see if this is your problem, try echoing display_errors or error_reporting. If you can't get that to work, just use phpinfo() and scroll to find them. If display_errors is off then you can do several things to rectify the situation.

The most common methods are to place ini_set('display_errors',1); and or error_reporting(E_WARNING | E_PARSE) at the top of your page, usually the header file so it only has to be typed once.

The next most common method (as I have never been able to get ini_set() or error_reporting() to work properly) is to place a php.ini file within each directory(folder) that displays pages with the single line of display_errors = 1. This method has always worked for me.

Hope this helps.

[Links]
http://www.php.net/manual/en/errorfunc.configuration.php#ini.display-errors
http://www.php.net/manual/en/function.error-reporting.php

Votes + Comments
agreed
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.