hi guys!

i've a mapped image and jquery in the following code, works fine with Chrome and Safari, but Firefox doesn't recognize the onclick function and I'm wondering why!

<img id="menu" src="/imgs/home/menuOK.png" border="0" align="left" usemap="Map_Menu"/>
<map name="Map_Menu" id="Map">
  <area shape="poly" coords="16,189,103,155,99,149,5,169" href="#" onclick="$('#contenuto').html('<iframe src=bio.php frameborder=no width=100% height=100% scrolling=no id=icontent><p>Your browser does not support iframes.</p></iframe>');" alt="Bio"/>
  <area shape="poly" coords="112,111,61,29,44,43,107,115" href="#" onClick="$('#contenuto').html('<iframe src=video.php frameborder=no width=100% height=100% scrolling=no id=icontent><p>Your browser does not support iframes.</p></iframe>');" alt="Video"/>
  <area shape="poly" coords="105,120,16,77,7,99,102,126" href="#" onClick="$('#contenuto').html('<iframe src=saundtrack.php frameborder=no width=100% height=100% scrolling=no id=icontent><p>Your browser does not support iframes.</p></iframe>');" alt="Saundtrack"/>
  <area shape="poly" coords="101,134,4,125,5,150,99,142" href="#" onClick="$('#contenuto').html('<iframe src=disco.php frameborder=no width=100% height=100% scrolling=no id=icontent><p>Your browser does not support iframes.</p></iframe>');" alt="Disco"/>
</map>

What version is your jquery? If it is not 1.4, it may still contain the bug when you try to insert inline html code in the area tag.

it's the 1.4.4, the last one..
thanks, at least I know now where the problem lies