0

when i try to use a sql sentence i juts get this error:
An attempt to attach an auto-named database for file C:\Documents and Settings\User1\Desktop\aweb1\User\App_Data\ASPNETDB.MDF failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.
now i am stucking with this for days now and it's quite urgent to fix it quikly
please can somebody help?

3
Contributors
5
Replies
6
Views
6 Years
Discussion Span
Last Post by aspproject
0

how do i do that?
"I had exactly the same error when setting up a new database for logging. The problem was solved when I discovered the file permissions for both the mdf and ldf were incorrect. To ensure that ASP.NET can access these files from the App_Data folder you will need to set to Inherit from parent the permission entries that apply to child objects as seen in the Advanced file security settings.

"

0

WOW I think i solved it!!!
i changed the name of the DATABASE in the folder, after that i created a new "App_Date" folder and put the DATABASE in it, after that i verified that the conncction is really to this folder and now it present a sql!

MANY MANY THANKS :D!

1

:) If you are done with you problem then mark this thread as solved before leaving

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.