0

I am using Joomla with the Ambra Subscriptions module to accept payments. When a new customer signs up and makes a payment, their account is not being automatically activated. I find myself having to activate every account manually after a new customer complains that they can't log in.

Under 'Site --> Global Configuration --> System --> User Settings', the "New User Account Activation" option was set to "No" but I changed it to "Yes" and the problem persists either way. The description of the "New User Account Activation Setting" says this:

If set to "Yes", the user will be e-mailed a link to activate their account before they can log in."

It doesn't matter if I set it to "Yes" or "No" because either way accounts are not being activated. I keep having to log in and activate accounts manually.

Here are the two things I don't want:

1) For the user to have to click a link in their e-mail to activate the account.
2) For the user to have to wait for me to manually activate their account.

I just want the user's account to be active as soon as they make a payment. No links to click, no having to wait for me.

Anyone know how to solve this?

4
Contributors
12
Replies
14
Views
6 Years
Discussion Span
Last Post by vectro
Featured Replies
  • Alright, so here are few things you can try. In the [ICODE]Global Config > Server > Mail Settings[/ICODE]. Make sure that the "Mail From" address is not the default "you@yourdomain.com" If that doesn't work, try changing [ICODE]Global Configuration < Server < Mail Settings < Mailer[/ICODE] to [ICODE]Sendmail[/ICODE]. And another possible … Read More

0

I've never used Joomla, and this really isn't a question about HTML or CSS.

  • Are your users even receiving the activation e-mail?
  • Is there a restart that Joomla needs to do? Is there a restart that you need to do?
  • Are there any delays between settings changes?
  • Is there a setting where you activate accounts that you need to change to allow automatic activation?
  • Does Joomla offer tech support or FAQs?

Regards
Arkinder

0

this really isn't a question about HTML or CSS.

There's no section in this forum for CMS or blogging.

Are your users even receiving the activation e-mail?

I don't know. Though, I'm aware that some people ignore it, delete it without thinking or it ends up in their spam folder and they don't realize it. That's why I'd prefer no activation e-mails involved.

Is there a restart that Joomla needs to do? Is there a restart that you need to do?

No.

Are there any delays between settings changes?

No.

Is there a setting where you activate accounts that you need to change to allow automatic activation?

Joomla only has 4 settings that control new accounts. The only one that seems related to activation is the verification e-mail setting. But toggling between 'Yes' and 'No' both seem to yield the same reaction from end-users (frustrated that their account is not auto-activated).

Does Joomla offer tech support or FAQs?

They have forums, and if worse comes to worse Ambra Subscriptions has paid support, but I'm trying to see if I can find a fix before I go that route.

0

If the user is receiving an e-mail and the activation link included works, then Joomla is working correctly. What you're wanting isn't offered as a general setting by Joomla.

Regards
Arkinder

0

If the user is receiving an e-mail and the activation link included works, then Joomla is working correctly. What you're wanting isn't offered as a general setting by Joomla.

You're right. I figured that out after some more Googling. I set it so the activation e-mail is sent. At least the user can activate the account themselves. The only problem now is that activation e-mails are not being sent. All other e-mails from Joomla to the user work fine, but activation e-mails are not getting to any of them.

1

Alright, so here are few things you can try. In the Global Config > Server > Mail Settings . Make sure that the "Mail From" address is not the default "you@yourdomain.com"

If that doesn't work, try changing Global Configuration < Server < Mail Settings < Mailer to Sendmail .

And another possible solution. Global Configuration < Server < Mail Settings < Mailer to SMTP using SSL , and remove any non a-z characters out of the From Name box.

These are just things that I've been able to find that other users used to fix that problem. As I said before, I've never used Joomla!. I hope that it helps regardless.

Regards
Arkinder

Votes + Comments
Thanks again
0

It depends, the above response may fix it, however let me know if you getting this on all new users or not? If just partially, then probably some of the users are trying to register with fake email address.

0

Alright, so here are few things you can try. In the Global Config > Server > Mail Settings . Make sure that the "Mail From" address is not the default "you@yourdomain.com"

That was already changed to the proper address a while ago.

These are just things that I've been able to find that other users used to fix that problem. As I said before, I've never used Joomla!. I hope that it helps regardless.

I'll try playing around with those settings. Any idea why one setting or another would prevent activation e-mails from going out but allows all other e-mails to be sent?

It depends, the above response may fix it, however let me know if you getting this on all new users or not? If just partially, then probably some of the users are trying to register with fake email address.

I'm using the Ambra subscriptions module and I have it set so that someone has to have a valid PayPal account in order to subscribe. That means people are singing up with valid addresses. The Joomla welcome e-mails arrive to them just fine, but not the activation e-mails.

0

Any idea why one setting or another would prevent activation e-mails from going out but allows all other e-mails to be sent?

Security. You, the admin, are being notified that a user needs activation and can manually activate the user. It's allowing you to screen each person before giving him or her access to your site. Joomla! just seems to have a not so user friendly interface.

Regards
Arkinder

0

Security. You, the admin, are being notified that a user needs activation and can manually activate the user. It's allowing you to screen each person before giving him or her access to your site. Joomla! just seems to have a not so user friendly interface.

Regards
Arkinder

I found two interesting things.

First, The Joomla wiki says that if 'User Registration' is set to 'No' then the account will be auto-activated without a verification e-mail. For now I changed it back to 'No'.

If set to No the user account will be activated immediately and the user can log in straight away (even if their email address is invalid).

Source: http://docs.joomla.org/Allowing_user_registration

The behavior I experienced does not match what the wiki claims.

Second, Joomla was outdated. I had 1.5.21 and just upgraded to 1.5.23. Maybe this and other loose ends will clear themselves up after the upgrade.

0

That's interesting. With the setting set to no are your users being validated? I'm sure the update will fix something. It just shouldn't be that difficult to activate users.

0

The update seems to have fixed it after all of that trouble. Thanks to everyone who helped!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.